gnome 2.18.0
authorDaniel Gryniewicz <dang@gentoo.org>
Tue, 27 Mar 2007 03:19:28 +0000 (03:19 +0000)
committerDaniel Gryniewicz <dang@gentoo.org>
Tue, 27 Mar 2007 03:19:28 +0000 (03:19 +0000)
Package-Manager: portage-2.1.2.2

gnome-base/gdm/ChangeLog
gnome-base/gdm/files/digest-gdm-2.18.0 [new file with mode: 0644]
gnome-base/gdm/files/gdm-2.18.0-gdm-dmx-intllibs.patch [new file with mode: 0644]
gnome-base/gdm/gdm-2.18.0.ebuild [new file with mode: 0644]
gnome-base/gnome-panel/ChangeLog
gnome-base/gnome-panel/files/digest-gnome-panel-2.18.0 [new file with mode: 0644]
gnome-base/gnome-panel/gnome-panel-2.18.0.ebuild [new file with mode: 0644]

index fca78702a2b2c13a37863241a60f5b29a6a85239..b2c5af79cfc94513d9045f1fe8f79c7270d91585 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for gnome-base/gdm
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/ChangeLog,v 1.203 2007/02/13 10:06:44 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/ChangeLog,v 1.204 2007/03/27 03:14:52 dang Exp $
+
+*gdm-2.18.0 (27 Mar 2007)
+
+  27 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
+  +files/gdm-2.18.0-gdm-dmx-intllibs.patch, +gdm-2.18.0.ebuild:
+  gnome 2.18.0
 
   13 Feb 2007; Roy Marples <uberlord@gentoo.org> ChangeLog:
   Add ~x86-fbsd keyword.
diff --git a/gnome-base/gdm/files/digest-gdm-2.18.0 b/gnome-base/gdm/files/digest-gdm-2.18.0
new file mode 100644 (file)
index 0000000..14b2bc8
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 a569a8275f0e0396e6ef5f63c5f56ad5 gdm-2.18.0.tar.bz2 3461709
+RMD160 6f23c30cdd51e4c71e9464808844156938b37316 gdm-2.18.0.tar.bz2 3461709
+SHA256 6619ef1ba04f4408f181b1a6c1d8a86f791706e22e0e2803153dbd5554a18053 gdm-2.18.0.tar.bz2 3461709
+MD5 a23df5fecb624744c016ad2fe8ebe5e8 gdm-2.8-gentoo-files-r2.tar.bz2 3101
+RMD160 b1776e987bf87e7db34d73bdf7a8eebfdcd51e54 gdm-2.8-gentoo-files-r2.tar.bz2 3101
+SHA256 c9335d71ab0a2ceca6a5959947aabf3728031e86dcb5536b7b57c6115c4ce53e gdm-2.8-gentoo-files-r2.tar.bz2 3101
+MD5 146b311aea6ca3b6b9bdbe551cb7c0ae gentoo-gdm-theme-r3.tar.bz2 411703
+RMD160 9188c8f2661163be72595a6b4924fae0648e7df5 gentoo-gdm-theme-r3.tar.bz2 411703
+SHA256 c7cbe97757ff93f0ffd42f9d9fb702278a361e830940a03901cda9943f44ba68 gentoo-gdm-theme-r3.tar.bz2 411703
diff --git a/gnome-base/gdm/files/gdm-2.18.0-gdm-dmx-intllibs.patch b/gnome-base/gdm/files/gdm-2.18.0-gdm-dmx-intllibs.patch
new file mode 100644 (file)
index 0000000..b375dad
--- /dev/null
@@ -0,0 +1,10 @@
+--- gdm-2.18.0/utils/Makefile.am       2006-01-15 16:26:35.000000000 -0500
++++ gdm-2.18.0/utils/Makefile.am       2006-01-31 15:51:20.000000000 -0500
+@@ -57,6 +57,7 @@
+       gdm-dmx-reconnect-proxy.c
+ gdm_dmx_reconnect_proxy_LDADD = \
++      $(INTLLIBS)             \
+       $(GLIB_LIBS) \
+       $(X_EXTRA_LIBS) \
+       $(X_LIBS) \
diff --git a/gnome-base/gdm/gdm-2.18.0.ebuild b/gnome-base/gdm/gdm-2.18.0.ebuild
new file mode 100644 (file)
index 0000000..8399a11
--- /dev/null
@@ -0,0 +1,188 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/gdm-2.18.0.ebuild,v 1.1 2007/03/27 03:14:52 dang Exp $
+
+inherit eutils pam gnome2
+
+DESCRIPTION="GNOME Display Manager"
+HOMEPAGE="http://www.gnome.org/projects/gdm/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="accessibility branding ipv6 pam selinux tcpd xinerama"
+
+# Name of the tarball with gentoo specific files
+GDM_EXTRA="${PN}-2.8-gentoo-files-r2"
+
+SRC_URI="${SRC_URI}
+                mirror://gentoo/${GDM_EXTRA}.tar.bz2
+                branding? ( mirror://gentoo/gentoo-gdm-theme-r3.tar.bz2 )"
+
+RDEPEND="pam?  (
+                                       virtual/pam
+                                       sys-auth/consolekit
+                               )
+       !pam? ( sys-apps/shadow )
+       >=dev-libs/glib-2.8
+       >=x11-libs/gtk+-2.6
+       >=x11-libs/pango-1.3
+       >=gnome-base/libglade-2
+       >=gnome-base/libgnomecanvas-2
+       >=gnome-base/librsvg-1.1.1
+       >=dev-libs/libxml2-2.4.12
+       >=media-libs/libart_lgpl-2.3.11
+       ||      (
+                       >=dev-libs/dbus-glib-0.71
+                       ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.35 )
+               )
+       accessibility? ( x11-libs/libXevie )
+       selinux? ( sys-libs/libselinux )
+       tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+       x11-libs/libX11
+       x11-libs/libXdmcp
+       x11-libs/libXi
+       x11-libs/libXext
+       x11-libs/libXinerama
+       x11-libs/libdmx
+       x11-libs/libXau
+       x11-apps/sessreg"
+DEPEND="${RDEPEND}
+       x11-proto/inputproto
+       x11-proto/dmxproto
+       sys-devel/gettext
+       app-admin/eselect
+       >=dev-util/pkgconfig-0.9
+       >=dev-util/intltool-0.35
+       >=app-text/gnome-doc-utils-0.3.2
+       >=app-text/scrollkeeper-0.1.4"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+MAKEOPTS="${MAKEOPTS} -j1"
+
+
+pkg_setup() {
+       G2CONF="--sysconfdir=/etc/X11         \
+               --localstatedir=/var              \
+               --with-xdmcp                      \
+               --with-pam-prefix=/etc            \
+               $(use_enable accessibility xevie) \
+               $(use_enable ipv6)                \
+               $(use_with selinux)               \
+               $(use_with tcpd tcp-wrappers)     \
+               $(use_with xinerama)"
+
+       if use pam; then
+               G2CONF="${G2CONF} --enable-authentication-scheme=pam \
+                                                 --with-console-kit=yes"
+       else
+               G2CONF="${G2CONF} --enable-console-helper=no \
+                                                 --enable-authentication-scheme=shadow \
+                                                 --with-console-kit=no"
+       fi
+
+       enewgroup gdm
+       enewuser gdm -1 -1 /var/lib/gdm gdm
+}
+
+src_unpack() {
+       gnome2_src_unpack
+
+       # remove unneeded linker directive for selinux (#41022)
+       epatch ${FILESDIR}/${PN}-2.13.0.1-selinux-remove-attr.patch
+
+       # Fix missing intllib
+       epatch ${FILESDIR}/${PN}-2.18.0-gdm-dmx-intllibs.patch
+}
+
+src_install() {
+       gnome2_src_install
+
+       local gentoodir="${WORKDIR}/${GDM_EXTRA}"
+
+       # gdm-binary should be gdm to work with our init (#5598)
+       rm -f ${D}/usr/sbin/gdm
+       dosym /usr/sbin/gdm-binary /usr/sbin/gdm
+
+       # our x11's scripts point to /usr/bin/gdm
+       dosym /usr/sbin/gdm-binary /usr/bin/gdm
+
+       # log, etc.
+       keepdir /var/log/gdm
+       keepdir /var/gdm
+
+       chown root:gdm ${D}/var/gdm
+       chmod 1770 ${D}/var/gdm
+
+       # use our own session script
+       rm -f ${D}/etc/X11/gdm/Xsession
+       exeinto /etc/X11/gdm
+       doexe ${gentoodir}/Xsession
+
+       # add a custom xsession .desktop by default (#44537)
+       exeinto /etc/X11/dm/Sessions
+       doexe ${gentoodir}/custom.desktop
+
+       # We replace the pam stuff by our own
+       rm -rf ${D}/etc/pam.d
+
+       dopamd ${gentoodir}/pam.d/*
+       dopamsecurity console.apps ${gentoodir}/security/console.apps/gdmsetup
+
+       # use graphical greeter local
+       dosed "s:#Greeter=/usr/libexec/gdmlogin:Greeter=/usr/libexec/gdmgreeter:" \
+               /usr/share/gdm/defaults.conf
+
+       # list available users
+       dosed "s:^#MinimalUID=.*:MinimalUID=1000:" /usr/share/gdm/defaults.conf
+       dosed "s:^#IncludeAll=.*:IncludeAll=true:" /usr/share/gdm/defaults.conf
+
+       # Fix old X11R6 paths
+       dosed "s:/usr/X11R6/bin:/usr/bin:" /usr/share/gdm/defaults.conf
+
+       # Move Gentoo theme in
+       if use branding ; then
+               mv ${WORKDIR}/gentoo-*  ${D}/usr/share/gdm/themes
+       fi
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+
+       einfo "To make GDM start at boot, edit /etc/rc.conf"
+       einfo "and then execute 'rc-update add xdm default'."
+
+       einfo "GDM has changed the location of its configuration file.  Please"
+       einfo "edit /etc/X11/gdm/custom.conf.  The factory defaults are located"
+       einfo "at /usr/share/gdm/{defaults.conf,factory-defaults.conf}"
+
+       einfo "See README.install for more information about the change."
+
+       if [ -f "/etc/X11/gdm/gdm.conf" ]; then
+               einfo "You had /etc/X11/gdm/gdm.conf which is the old configuration"
+               einfo "file.  It has been moved to /etc/X11/gdm/gdm-pre-gnome-2.16"
+               mv /etc/X11/gdm/gdm.conf /etc/X11/gdm/gdm-pre-gnome-2.16
+       fi
+
+       # Soft restart, assumes Gentoo defaults for file locations
+       # Do restart after gdm.conf move above
+       FIFOFILE=/var/gdm/.gdmfifo
+       PIDFILE=/var/run/gdm.pid
+
+       if [ -w ${FIFOFILE} ] ; then
+               if [ -f ${PIDFILE} ] ; then
+                       if kill -0 `cat ${PIDFILE}`; then
+                               (echo;echo SOFT_RESTART) >> ${FIFOFILE}
+                       fi
+               fi
+       fi
+}
+
+pkg_postrm() {
+       gnome2_pkg_postrm
+
+       if [[ "$(rc-config list default | grep xdm)" != "" ]] ; then
+               einfo "To remove GDM from startup please execute"
+               einfo "'rc-update del xdm default'"
+       fi
+}
index 2365c3841f77d83320f4a275d5472dae44aaa9b3..e90e63d696bf69ed35c3a3a72a7707239a19f819 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for gnome-base/gnome-panel
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/ChangeLog,v 1.208 2007/02/21 00:24:50 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/ChangeLog,v 1.209 2007/03/27 03:19:28 dang Exp $
+
+*gnome-panel-2.18.0 (27 Mar 2007)
+
+  27 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
+  +gnome-panel-2.18.0.ebuild:
+  gnome 2.18.0
 
 *gnome-panel-2.16.3 (21 Feb 2007)
 
diff --git a/gnome-base/gnome-panel/files/digest-gnome-panel-2.18.0 b/gnome-base/gnome-panel/files/digest-gnome-panel-2.18.0
new file mode 100644 (file)
index 0000000..256d354
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 67ab5a4df1817fe14572d9e366664665 gnome-panel-2.18.0.tar.bz2 2706385
+RMD160 b681a4d96e4ccc6e727f405abf4fd2c45c5e670a gnome-panel-2.18.0.tar.bz2 2706385
+SHA256 856c5205878bd0bee4bc7e62bdc7ecfce560aa233d2acfaf17a61d5ec446ef46 gnome-panel-2.18.0.tar.bz2 2706385
diff --git a/gnome-base/gnome-panel/gnome-panel-2.18.0.ebuild b/gnome-base/gnome-panel/gnome-panel-2.18.0.ebuild
new file mode 100644 (file)
index 0000000..c9bac7a
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/gnome-panel-2.18.0.ebuild,v 1.1 2007/03/27 03:19:28 dang Exp $
+
+inherit gnome2
+
+DESCRIPTION="The GNOME panel"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc eds"
+
+RDEPEND=">=gnome-base/gnome-desktop-2.12
+       >=x11-libs/gtk+-2.10
+       >=gnome-base/libglade-2.5
+       >=gnome-base/libgnome-2.13
+       >=gnome-base/libgnomeui-2.5.4
+       >=gnome-base/libbonoboui-2.1.1
+       >=gnome-base/orbit-2.4
+       >=gnome-base/gnome-vfs-2.14.2
+       >=x11-libs/libwnck-2.13.5
+       >=gnome-base/gconf-2.6.1
+       >=gnome-base/gnome-menus-2.11.1
+       >=gnome-base/libbonobo-2
+       ||  (
+                       >=dev-libs/dbus-glib-0.71
+                       ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.60 )
+               )
+       x11-libs/libXau
+       media-libs/libpng
+       >=x11-libs/cairo-1.0.0
+       >=x11-libs/pango-1.15.4
+       eds? ( >=gnome-extra/evolution-data-server-1.6 )"
+DEPEND="${RDEPEND}
+       app-text/scrollkeeper
+       >=dev-util/pkgconfig-0.9
+       >=dev-util/intltool-0.35
+       >=app-text/gnome-doc-utils-0.3.2
+       doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+       G2CONF="--disable-scrollkeeper $(use_enable eds) \
+                       --with-in-process-applets=clock,notification-area,wncklet"
+}
+
+src_unpack() {
+       gnome2_src_unpack
+
+       # FIXME : uh yeah, this is nice
+       # We should patch in a switch here and send it upstream
+       sed -i 's:--load:-v:' ${S}/gnome-panel/Makefile.in || die "sed failed"
+}
+
+pkg_postinst() {
+       local entries="/etc/gconf/schemas/panel-default-setup.entries"
+       if [ -e "$entries" ]; then
+               einfo "setting panel gconf defaults..."
+               GCONF_CONFIG_SOURCE=`${ROOT}/usr/bin/gconftool-2 --get-default-source`
+               ${ROOT}/usr/bin/gconftool-2 --direct --config-source \
+                       ${GCONF_CONFIG_SOURCE} --load=${entries}
+       fi
+
+       # Calling this late so it doesn't process the GConf schemas file we already
+       # took care of.
+       gnome2_pkg_postinst
+}