dev-ros/pointcloud_to_laserscan: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 11:51:13 +0000 (13:51 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 11:52:23 +0000 (13:52 +0200)
Package-Manager: portage-2.2.21

dev-ros/pointcloud_to_laserscan/Manifest [new file with mode: 0644]
dev-ros/pointcloud_to_laserscan/metadata.xml [new file with mode: 0644]
dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.0.ebuild [new file with mode: 0644]
dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/pointcloud_to_laserscan/Manifest b/dev-ros/pointcloud_to_laserscan/Manifest
new file mode 100644 (file)
index 0000000..3ba78e8
--- /dev/null
@@ -0,0 +1 @@
+DIST pointcloud_to_laserscan-1.3.0.tar.gz 6115 SHA256 704b79a179f415a71acb4c4c42793a49bd0a018ec6b1e2c71a3592decd8f4585 SHA512 a41b1c42048dde6ee73ca33f71e8e39354e4ebc0e91274eee590497d703c6ea9e0954e79d24cf828c3c1eac68377f894c728cff26b46a73f0d8cd3d7f6195c00 WHIRLPOOL edb45d94730c36c1fc617df43d52d24c15d23f05c4e9452a12d610578c175396dbe2129be51e00cf9191696284f1b7f3cfd4a6b670cf2adb5c2b87b230d93816
diff --git a/dev-ros/pointcloud_to_laserscan/metadata.xml b/dev-ros/pointcloud_to_laserscan/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.0.ebuild b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.0.ebuild
new file mode 100644 (file)
index 0000000..2f960a5
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/pointcloud_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a 3D Point Cloud into a 2D laser scan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/message_filters
+       dev-ros/nodelet
+       dev-ros/roscpp
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf2
+       dev-ros/tf2_ros
+       dev-ros/tf2_sensor_msgs
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild
new file mode 100644 (file)
index 0000000..2f960a5
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/pointcloud_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a 3D Point Cloud into a 2D laser scan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/message_filters
+       dev-ros/nodelet
+       dev-ros/roscpp
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf2
+       dev-ros/tf2_ros
+       dev-ros/tf2_sensor_msgs
+"
+DEPEND="${RDEPEND}"