dev-util/geany-plugins: make libgit2-0.99 compatible
authorChris Mayo <aklhfex@gmail.com>
Sun, 8 Mar 2020 19:41:19 +0000 (19:41 +0000)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 14:12:12 +0000 (16:12 +0200)
Closes: https://bugs.gentoo.org/711550
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Chris Mayo <aklhfex@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14837
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-util/geany-plugins/files/geany-plugins-1.36-libgit2-0.99.patch [new file with mode: 0644]
dev-util/geany-plugins/geany-plugins-1.36-r1.ebuild

diff --git a/dev-util/geany-plugins/files/geany-plugins-1.36-libgit2-0.99.patch b/dev-util/geany-plugins/files/geany-plugins-1.36-libgit2-0.99.patch
new file mode 100644 (file)
index 0000000..25e5ac4
--- /dev/null
@@ -0,0 +1,55 @@
+From 9497d829e1b207eb83575dc6f617feecfb89bc16 Mon Sep 17 00:00:00 2001
+From: Dominik Schmidt <dominik@schm1dt.ch>
+Date: Sun, 23 Feb 2020 19:15:30 +0100
+Subject: [PATCH] Make libgit2 version preprocessor conditionals compatible
+ with libgit2-0.99
+
+LIBGIT2_SOVERSION is defined as string literal, e.g. "0.99",
+from libgit2-0.99 and beyond. Arithmetic checks against this
+variable whill hence fail. This patch switches the checks to
+compare against the LIBGIT2_VER_* family, which should be more stable.
+---
+ git-changebar/src/gcb-plugin.c | 6 +++---
+ workbench/src/plugin_main.c    | 2 +-
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/git-changebar/src/gcb-plugin.c b/git-changebar/src/gcb-plugin.c
+index b7083199..a911815f 100644
+--- a/git-changebar/src/gcb-plugin.c
++++ b/git-changebar/src/gcb-plugin.c
+@@ -32,11 +32,11 @@
+ #include <geany.h>
+ #include <document.h>
+-#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 22
++#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 22) )
+ # define git_libgit2_init     git_threads_init
+ # define git_libgit2_shutdown git_threads_shutdown
+ #endif
+-#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 23
++#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 23) )
+ /* 0.23 added @p binary_cb */
+ # define git_diff_buffers(old_buffer, old_len, old_as_path, \
+                           new_buffer, new_len, new_as_path, options, \
+@@ -45,7 +45,7 @@
+                     new_buffer, new_len, new_as_path, options, \
+                     file_cb, hunk_cb, line_cb, payload)
+ #endif
+-#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 28
++#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 28) )
+ # define git_buf_dispose  git_buf_free
+ # define git_error_last   giterr_last
+ #endif
+diff --git a/workbench/src/plugin_main.c b/workbench/src/plugin_main.c
+index 6fa6fc84..25ecdf6d 100644
+--- a/workbench/src/plugin_main.c
++++ b/workbench/src/plugin_main.c
+@@ -36,7 +36,7 @@
+ #include "tm_control.h"
+-#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 22
++#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 22))
+ # define git_libgit2_init     git_threads_init
+ # define git_libgit2_shutdown git_threads_shutdown
+ #endif
index a52dca03895f60ad529a8732dfda915c0cfd6fc4..d893f9de3ae970eca09862cc0ec62d64bd14c210 100644 (file)
@@ -69,6 +69,8 @@ BDEPEND="virtual/pkgconfig
        nls? ( sys-devel/gettext )
 "
 
+PATCHES=( "${FILESDIR}"/${P}-libgit2-0.99.patch )
+
 pkg_setup() {
        use python && python-single-r1_pkg_setup
 }