version bump a month late, and nobody told me :(
authorSeemant Kulleen <seemant@gentoo.org>
Thu, 8 Jun 2006 20:02:59 +0000 (20:02 +0000)
committerSeemant Kulleen <seemant@gentoo.org>
Thu, 8 Jun 2006 20:02:59 +0000 (20:02 +0000)
Package-Manager: portage-2.1_rc4-r3

media-libs/libdc1394/ChangeLog
media-libs/libdc1394/files/digest-libdc1394-2.0.0_pre7 [new file with mode: 0644]
media-libs/libdc1394/libdc1394-2.0.0_pre7.ebuild [new file with mode: 0644]

index 390b870c94aa073a022d19a8139baf2e6be2a077..31d2b8b550f66b9ed1cd78020c05823aaac3494c 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for media-libs/libdc1394
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/ChangeLog,v 1.21 2006/05/03 14:34:23 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/ChangeLog,v 1.22 2006/06/08 20:02:59 seemant Exp $
+
+*libdc1394-2.0.0_pre7 (08 Jun 2006)
+
+  08 Jun 2006; Seemant Kulleen <seemant@gentoo.org> -libdc1394-1.0.0.ebuild,
+  -libdc1394-2.0.0_pre5-r1.ebuild, -libdc1394-2.0.0_pre6-r1.ebuild,
+  +libdc1394-2.0.0_pre7.ebuild:
+  version bump a month late, and nobody told me :(
 
   03 May 2006; Seemant Kulleen <seemant@gentoo.org> libdc1394-1.0.0.ebuild,
   libdc1394-2.0.0_pre4.ebuild, libdc1394-2.0.0_pre5-r1.ebuild,
diff --git a/media-libs/libdc1394/files/digest-libdc1394-2.0.0_pre7 b/media-libs/libdc1394/files/digest-libdc1394-2.0.0_pre7
new file mode 100644 (file)
index 0000000..724bf2b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b826164d91c4c8dae668cb138cd75b01 libdc1394-2.0.0-pre7.tar.gz 410416
+RMD160 529527ba2c91d4567477d8e32b5975d0c9f49c77 libdc1394-2.0.0-pre7.tar.gz 410416
+SHA256 a737f0cdc2e0d77e829cac61b12bbea2ad00f65a637c09ec9c2189fb2938fe41 libdc1394-2.0.0-pre7.tar.gz 410416
diff --git a/media-libs/libdc1394/libdc1394-2.0.0_pre7.ebuild b/media-libs/libdc1394/libdc1394-2.0.0_pre7.ebuild
new file mode 100644 (file)
index 0000000..bb03ec9
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/libdc1394-2.0.0_pre7.ebuild,v 1.1 2006/06/08 20:02:59 seemant Exp $
+
+inherit eutils
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="library for controling IEEE 1394 conforming based cameras"
+HOMEPAGE="http://sourceforge.net/projects/libdc1394/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X"
+
+RDEPEND=">=sys-libs/libraw1394-1.2.0
+               X? ( || ( ( x11-libs/libSM x11-libs/libXv )
+                                 virtual/x11 ) )"
+DEPEND="!=sys-libs/libdc1394-2*
+       ${RDEPEND}
+       sys-devel/libtool"
+
+src_compile() {
+       econf \
+               --program-suffix=2 \
+               $(use_with X x) || die
+       emake || die "emake failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die
+       dodoc NEWS README AUTHORS ChangeLog
+}