Version bump.
authorMike Frysinger <vapier@gentoo.org>
Tue, 18 Oct 2011 17:46:20 +0000 (17:46 +0000)
committerMike Frysinger <vapier@gentoo.org>
Tue, 18 Oct 2011 17:46:20 +0000 (17:46 +0000)
Package-Manager: portage-2.2.0_alpha65/cvs/Linux x86_64

sys-devel/crossdev/ChangeLog
sys-devel/crossdev/crossdev-20111018.ebuild [new file with mode: 0644]
sys-devel/libtool/ChangeLog
sys-devel/libtool/libtool-2.4.2.ebuild [new file with mode: 0644]

index 7f3c34b6ad65dae05fb498e5a1215f5246f388d2..32ee22fb8dda5335f860587e80beb0a1aedb3788 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sys-devel/crossdev
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.83 2011/10/11 22:23:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.84 2011/10/18 17:46:20 vapier Exp $
+
+*crossdev-20111018 (18 Oct 2011)
+
+  18 Oct 2011; Mike Frysinger <vapier@gentoo.org> +crossdev-20111018.ebuild:
+  Version bump.
 
 *crossdev-20111011 (11 Oct 2011)
 
diff --git a/sys-devel/crossdev/crossdev-20111018.ebuild b/sys-devel/crossdev/crossdev-20111018.ebuild
new file mode 100644 (file)
index 0000000..928ec9b
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20111018.ebuild,v 1.1 2011/10/18 17:46:20 vapier Exp $
+
+EAPI="3"
+
+if [[ ${PV} == "99999999" ]] ; then
+       EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+       inherit git-2
+       SRC_URI=""
+       #KEYWORDS=""
+else
+       SRC_URI="mirror://gentoo/${P}.tar.xz
+               http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+       app-shells/bash
+       !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+       emake install DESTDIR="${D}" || die
+}
index 1f13d24d85e646473247823eb28336e860ef8aaa..913d75dbd2568054850cd7ef177a49a85febca86 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sys-devel/libtool
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.194 2011/10/04 20:42:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.195 2011/10/18 17:46:03 vapier Exp $
+
+*libtool-2.4.2 (18 Oct 2011)
+
+  18 Oct 2011; Mike Frysinger <vapier@gentoo.org> +libtool-2.4.2.ebuild:
+  Version bump.
 
   04 Oct 2011; Mike Frysinger <vapier@gentoo.org> libtool-2.2.10.ebuild,
   libtool-2.4-r1.ebuild, libtool-2.4-r3.ebuild, libtool-9999.ebuild:
diff --git a/sys-devel/libtool/libtool-2.4.2.ebuild b/sys-devel/libtool/libtool-2.4.2.ebuild
new file mode 100644 (file)
index 0000000..b0f796a
--- /dev/null
@@ -0,0 +1,88 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.4.2.ebuild,v 1.1 2011/10/18 17:46:03 vapier Exp $
+
+EAPI="2" #356089
+
+LIBTOOLIZE="true" #225559
+WANT_LIBTOOL="none"
+inherit eutils autotools multilib
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
+               http://git.savannah.gnu.org/r/${PN}.git"
+       inherit git-2
+else
+       SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+       #KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="A shared library tool for developers"
+HOMEPAGE="http://www.gnu.org/software/libtool/"
+
+LICENSE="GPL-2"
+SLOT="2"
+IUSE="static-libs test vanilla"
+
+RDEPEND="sys-devel/gnuconfig
+       !<sys-devel/autoconf-2.62:2.5
+       !<sys-devel/automake-1.11.1:1.11
+       !=sys-devel/libtool-2*:1.5"
+DEPEND="${RDEPEND}
+       test? ( !<sys-devel/binutils-2.20 )
+       app-arch/xz-utils"
+[[ ${PV} == "9999" ]] && DEPEND+=" sys-apps/help2man"
+
+src_unpack() {
+       if [[ ${PV} == "9999" ]] ; then
+               git-2_src_unpack
+               cd "${S}"
+               ./bootstrap || die
+       else
+               xz -dc "${DISTDIR}"/${A} > ${P}.tar #356089
+               unpack ./${P}.tar
+       fi
+}
+
+src_prepare() {
+       use vanilla && return 0
+
+       epunt_cxx
+       cd libltdl/m4
+       epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
+       cd ..
+       AT_NOELIBTOOLIZE=yes eautoreconf
+       cd ..
+       AT_NOELIBTOOLIZE=yes eautoreconf
+}
+
+src_configure() {
+       # the libtool script uses bash code in it and at configure time, tries
+       # to find a bash shell.  if /bin/sh is bash, it uses that.  this can
+       # cause problems for people who switch /bin/sh on the fly to other
+       # shells, so just force libtool to use /bin/bash all the time.
+       export CONFIG_SHELL=/bin/bash
+
+       econf $(use_enable static-libs static)
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die
+       dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
+
+       # While the libltdl.la file is not used directly, the m4 ltdl logic
+       # keys off of its existence when searching for ltdl support. #293921
+       #use static-libs || find "${D}" -name libltdl.la -delete
+
+       for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
+               rm -f "${x}" ; ln -sf /usr/share/gnuconfig/${x##*/} "${x}"
+       done
+}
+
+pkg_preinst() {
+       preserve_old_lib /usr/$(get_libdir)/libltdl.so.3
+}
+
+pkg_postinst() {
+       preserve_old_lib_notify /usr/$(get_libdir)/libltdl.so.3
+}