dev-python/mkdocs: version bump 1.1
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Sat, 28 Mar 2020 14:12:28 +0000 (15:12 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 9 Apr 2020 12:37:42 +0000 (15:37 +0300)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/mkdocs/Manifest
dev-python/mkdocs/metadata.xml
dev-python/mkdocs/mkdocs-1.1.ebuild [new file with mode: 0644]

index 1ffda6972b2f80d2b8d4661242de6ad6faeaabcd..9dabb9467fcee1782514423147fa95374cace58b 100644 (file)
@@ -1,2 +1,3 @@
 DIST mkdocs-0.15.3.tar.gz 1805972 BLAKE2B e6619fa0bd14fefe96de5abeb9243369b1419e7018705ac6a6d58fcb40c01aff380c3b4ca514af0a25da90092f39776abe42d19a67f7e86780c5c4111884b230 SHA512 e5b72eb56dcc2fe2be154155af15845a7d0fc06d6176f1c6b2bb54e8673d207146bdd92b37a709d72c1d59fcc76a793e6fed5d7fb6d9008f28d43baa17e446f8
 DIST mkdocs-1.0.1.tar.gz 1589767 BLAKE2B 54f7a33c166fa44b9471069db45436e1381d451470fea4ed11de1cabc0cead3508bffbaf2303d33904ef0bee8f81cfbdacb0fd095ee53d6fa7c09f33274c03af SHA512 9f6b1ff5922fb58783d70f3912bb0170f927ba0160f5e48f71db2d267030208bd50997f14f4626fbfce891ddce7f97747ba05100ea96cdc24609341d382f039a
+DIST mkdocs-1.1.tar.gz 6984465 BLAKE2B 878d0351ac477651094b5f33a26d5faa444fed430b72df723d4fe020ee8d6953ee198a9e923aa79a04286445ff673e1d6967ca1740d8f02b37426b33038f76fb SHA512 3e846eac816d9a4f380e2cce856a1785b67c9d855392af8be2eb0de5c9aad7ead19e675fb36ff53e9e3046798c8691908c1d6bfec67f8c74dcaee6852b9c50cd
index 251c93451e3dd77d4d109c8cb68a135deb67e250..5d57d454ac2f25e2ec20a665fdb20a182d01f334 100644 (file)
@@ -1,7 +1,14 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!--maintainer-needed-->
+       <maintainer type="person">
+               <email>andrewammerlaan@riseup.net</email>
+               <name>Andrew Ammerlaan</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
        <upstream>
                <remote-id type="github">tomchristie/mkdocs</remote-id>
        </upstream>
diff --git a/dev-python/mkdocs/mkdocs-1.1.ebuild b/dev-python/mkdocs/mkdocs-1.1.ebuild
new file mode 100644 (file)
index 0000000..fde7445
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Project documentation with Markdown."
+HOMEPAGE="https://www.mkdocs.org https://github.com/mkdocs/mkdocs"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+
+BDEPEND="
+       doc? (
+               dev-python/mdx_gh_links
+       )
+"
+
+RDEPEND="
+       >=dev-python/click-3.3[${PYTHON_USEDEP}]
+       >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+       >=dev-python/livereload-2.5.1[${PYTHON_USEDEP}]
+       ~dev-python/lunr-0.5.6[${PYTHON_USEDEP}]
+       >=dev-python/markdown-3.2.1[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+       >=www-servers/tornado-5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+python_prepare_all(){
+       # cannot get all themes
+       sed -i -e 's:test_get_themes:_&:' mkdocs/tests/utils/utils_tests.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       default
+       if use doc; then
+               # cannot just do mkdocs build, because that fails if
+               # the package isn't already installed
+               python -m mkdocs build || die "Failed to make docs"
+               # Colliding files found by ecompress:
+               rm site/sitemap.xml.gz || die
+               HTML_DOCS=( "site/." )
+       fi
+}