dev-python/dogpile-core: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:12:15 +0000 (17:12 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:12:15 +0000 (17:12 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/dogpile-core/dogpile-core-0.4.1.ebuild

index b9a85e397e168e04baa5790be5410dd62ee8a240..e614c9cc57a90bce98615ff361294b43e70dd5bb 100644 (file)
@@ -2,11 +2,11 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
 
 inherit distutils-r1
 
-DESCRIPTION="A lock which allows a thread to generate an expensive resource while other threads use the old value"
+DESCRIPTION="Copy-on-write locking mechanism for expensive resources"
 HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.core"
 SRC_URI="mirror://pypi/${PN:0:1}/dogpile.core/dogpile.core-${PV}.tar.gz"
 S="${WORKDIR}/dogpile.core-${PV}"