sys-apps/debianutils: Bump to version 4.11
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 30 May 2020 08:37:44 +0000 (10:37 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 30 May 2020 08:54:05 +0000 (10:54 +0200)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/debianutils/Manifest
sys-apps/debianutils/debianutils-4.11.ebuild [new file with mode: 0644]

index e53b44c2246b58da213a2b5026d6d876a8409428..a87335be93eaf7c89a0f2a1aedfa30f36b6a5910 100644 (file)
@@ -1,2 +1,3 @@
+DIST debianutils_4.11.tar.xz 157440 BLAKE2B a0238a97b2700119570ee80e4fb85c36a44ac6fa700fc927bda85bd5358ff364f19389160e4a01685c7263e8b3855b63197590dc65825002e532bfea98ef9f5c SHA512 87f6b7d9fecbaff615a5529328d384d8adf4ed69c8cc00acc54681d91fc146f4241a761dde2c9b092cb279b63d30dcaa6c2d0309ef4d29d6a2b09600c53c0ac6
 DIST debianutils_4.9.1.tar.xz 157516 BLAKE2B b2c8927e37448f4e45f19b4a7d2977198d2c610a203a2c8692a0592c8c8319c5dc42050b83435cb7381e30cc653911083b76717a53ac908113cc7388a4155167 SHA512 b442950febe6df9e15ec04a6fec0ee8be12d3eac38dc3f9331438d871e3382f4e0f599da0eaeff0e7e9ba0fa5136ce3c3b51c6718e4d7f11c1675f745052a9b1
 DIST debianutils_4.9.3.tar.xz 157404 BLAKE2B 527844c0bd623f3b560d544f6f041f7db7dc39c225333427bb81a5044975005b288cde58e9dfaf7f633f706f78e4ff33132c149cd6f0e918852f1170c0ae2c32 SHA512 6c5771c4737c48c9ca0cf01ad58102190d78ece41e66306a4bdf30cd7ea784a325df2a4a2b7ba371d9ba5aebaee8cf87286c423a8eff54dbfe8eb6de58eda532
diff --git a/sys-apps/debianutils/debianutils-4.11.ebuild b/sys-apps/debianutils/debianutils-4.11.ebuild
new file mode 100644 (file)
index 0000000..ecc8cf6
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="https://packages.qa.debian.org/d/debianutils.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="BSD GPL-2 SMAIL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="+installkernel static"
+
+PDEPEND="
+       installkernel? (
+               || (
+                       sys-kernel/installkernel-gentoo
+                       sys-kernel/installkernel-systemd-boot
+               )
+       )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.2-no-bs-namespace.patch )
+
+src_configure() {
+       use static && append-ldflags -static
+       default
+}
+
+src_install() {
+       into /
+       dobin tempfile run-parts
+
+       into /usr
+       dobin ischroot
+       dosbin savelog
+
+       doman ischroot.1 tempfile.1 run-parts.8 savelog.8
+       cd debian || die
+       dodoc changelog control
+}