dev-python/urllib3: Disable tests for py2 to unblock tornado
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 07:10:53 +0000 (08:10 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 09:39:47 +0000 (10:39 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/urllib3/urllib3-1.24.2.ebuild
dev-python/urllib3/urllib3-1.25.7.ebuild
dev-python/urllib3/urllib3-1.25.8.ebuild

index 744dfd74e26d8c91f347684d2c2fe49434995d38..7be6c90f2f82700e0224e93f558edaa2be07f288 100644 (file)
@@ -32,10 +32,12 @@ RDEPEND="
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
-               ${RDEPEND}
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               >=www-servers/tornado-4.2.1[$(python_gen_usedep python{2_7,3_{5,6,7}})]
+               $(python_gen_cond_dep "
+                       ${RDEPEND}
+                       dev-python/mock[\${PYTHON_USEDEP}]
+                       dev-python/pytest[\${PYTHON_USEDEP}]
+                       >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+               " 'python3*')
        )
 "
 
@@ -53,7 +55,12 @@ python_prepare_all() {
 python_test() {
        # FIXME: get tornado ported
        case ${EPYTHON} in
-               python2*|python3.[567])
+               python2*)
+                       ewarn "Tests are being skipped for Python 2 in order to reduce the number"
+                       ewarn "of circular dependencies for Python 2 removal.  Please test"
+                       ewarn "manually in a virtualenv."
+                       ;;
+               python3*)
                        pytest -vv || die "Tests fail with ${EPYTHON}"
                        ;;
        esac
index de5188583cf731b9f0b9441735eb17282f5c79f1..7dec43ea895045f37da8f47f88fee7310d8b32e0 100644 (file)
@@ -33,14 +33,14 @@ RDEPEND="
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
-               ${RDEPEND}
-               dev-python/brotlipy[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               >=dev-python/trustme-0.5.3[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep '
-                       >=www-servers/tornado-4.2.1[${PYTHON_USEDEP}]
-               ' python{2_7,3_{5,6,7}})
+               $(python_gen_cond_dep "
+                       ${RDEPEND}
+                       dev-python/brotlipy[\${PYTHON_USEDEP}]
+                       dev-python/mock[\${PYTHON_USEDEP}]
+                       dev-python/pytest[\${PYTHON_USEDEP}]
+                       >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+                       >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+               " 'python3*')
        )
 "
 
@@ -72,7 +72,12 @@ python_prepare_all() {
 python_test() {
        # FIXME: get tornado ported
        case ${EPYTHON} in
-               python2*|python3.[567])
+               python2*)
+                       ewarn "Tests are being skipped for Python 2 in order to reduce the number"
+                       ewarn "of circular dependencies for Python 2 removal.  Please test"
+                       ewarn "manually in a virtualenv."
+                       ;;
+               python3*)
                        pytest -vv || die "Tests fail with ${EPYTHON}"
                        ;;
        esac
index e21205e47f94f521123fc26210d3dc76baae5407..5ac937b017b5beae8e1ce60780e05917092c0f86 100644 (file)
@@ -33,14 +33,14 @@ RDEPEND="
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
-               ${RDEPEND}
-               dev-python/brotlipy[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               >=dev-python/trustme-0.5.3[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep '
-                       >=www-servers/tornado-4.2.1[${PYTHON_USEDEP}]
-               ' 'python*')
+               $(python_gen_cond_dep "
+                       ${RDEPEND}
+                       dev-python/brotlipy[\${PYTHON_USEDEP}]
+                       dev-python/mock[\${PYTHON_USEDEP}]
+                       dev-python/pytest[\${PYTHON_USEDEP}]
+                       >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+                       >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+               " 'python3*')
        )
 "
 
@@ -73,7 +73,12 @@ python_test() {
        local -x CI=1
        # FIXME: get tornado ported
        case ${EPYTHON} in
-               python*)
+               python2*)
+                       ewarn "Tests are being skipped for Python 2 in order to reduce the number"
+                       ewarn "of circular dependencies for Python 2 removal.  Please test"
+                       ewarn "manually in a virtualenv."
+                       ;;
+               python3*)
                        pytest -vv || die "Tests fail with ${EPYTHON}"
                        ;;
        esac