games-arcade/gnome-robots: bump to 3.36.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 22 Mar 2020 16:28:16 +0000 (18:28 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 22 Mar 2020 16:49:15 +0000 (18:49 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
games-arcade/gnome-robots/Manifest
games-arcade/gnome-robots/gnome-robots-3.36.0.ebuild [new file with mode: 0644]

index 7a4d395ceb851017592d07a1c7a7a070c8b75faf..a8f36ac6ae69e49c87958c52b7a24be52246baa4 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-robots-3.32.0.tar.xz 422684 BLAKE2B bf66057da9ed52ffe641d28aa522d7851a1ac7881369d1329507beffdeb3f9dc6a46988993c899783576e8c63730245dd340b62267809d1334515dabc2d599e4 SHA512 b037d576eea45843ae4c13ddf284a598931b295257688f6fa458fb4e33b987c01dd70d34007703b3f7bcb97cf8aa306e6473e4c24e5ee0253f1beaafcff1c6f7
+DIST gnome-robots-3.36.0.tar.xz 425616 BLAKE2B 1d5a3a0a087ace46af17fd97d7c284ba722d9bec22b9694ebd16b3d18fe1d87e656c6dcfc7b4687c60ea5015577c8319d967b8ad705d3d4d5e398df35c392068 SHA512 8e5eb03f74c1092c26148d0818c9e8118144dbb70c6cb25db449316ede05ff892a9ad06df2e8dc9942fe8c4f5ae638a1c8a8cda381f78f6f01a80c19010df35a
diff --git a/games-arcade/gnome-robots/gnome-robots-3.36.0.ebuild b/games-arcade/gnome-robots/gnome-robots-3.36.0.ebuild
new file mode 100644 (file)
index 0000000..fc66f1d
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Avoid the robots and make them crash into each other"
+HOMEPAGE="https://wiki.gnome.org/Apps/Robots"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-libs/glib-2.32:2
+       dev-libs/libgnome-games-support:1=
+       >=media-libs/gsound-1.0.2
+       >=x11-libs/gtk+-3.15:3
+       >=gnome-base/librsvg-2.36.2:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-libs/appstream-glib
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}