dev-python/bottleneck: Combine ebuilds (remove py2)
authorMichał Górny <mgorny@gentoo.org>
Tue, 28 Jan 2020 20:53:24 +0000 (21:53 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 28 Jan 2020 21:30:10 +0000 (22:30 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/bottleneck/bottleneck-1.2.1-r1.ebuild
dev-python/bottleneck/bottleneck-1.2.1.ebuild [deleted file]

index 833b7c25e772d4470ff69ae33422364785bdb30d..ffe790c6fe3b1409ada04b87e62b91b326bebe01 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/kwgoodman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
 
 SLOT="0"
 LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
diff --git a/dev-python/bottleneck/bottleneck-1.2.1.ebuild b/dev-python/bottleneck/bottleneck-1.2.1.ebuild
deleted file mode 100644 (file)
index 6221eaf..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast NumPy array functions written in Cython"
-HOMEPAGE="https://pypi.org/project/Bottleneck/"
-SRC_URI="https://github.com/kwgoodman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/numpy-1.9.1[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose )"
-
-python_test() {
-       ${EPYTHON} ./tools/test-installed-bottleneck.py
-}