sys-libs/libomp: Add a live ebuild
authorMichał Górny <mgorny@gentoo.org>
Wed, 14 Sep 2016 14:54:39 +0000 (16:54 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 23 Sep 2016 07:29:03 +0000 (09:29 +0200)
sys-libs/libomp/libomp-9999.ebuild [new file with mode: 0644]

diff --git a/sys-libs/libomp/libomp-9999.ebuild b/sys-libs/libomp/libomp-9999.ebuild
new file mode 100644 (file)
index 0000000..fe4be82
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+
+inherit cmake-multilib git-r3
+
+DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
+HOMEPAGE="http://openmp.llvm.org"
+SRC_URI=""
+EGIT_REPO_URI="http://llvm.org/git/openmp.git
+       https://github.com/llvm-mirror/openmp.git"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+multilib_src_configure() {
+       local libdir="$(get_libdir)"
+       local mycmakeargs=(
+               -DLIBOMP_LIBDIR_SUFFIX="${libdir#lib}"
+               # do not install libgomp.so & libiomp5.so aliases
+               -DLIBOMP_INSTALL_ALIASES=OFF
+       )
+       cmake-utils_src_configure
+}