net-misc/pycnb: Fix permissions on files in ${S}
authorMike Gilbert <floppym@gentoo.org>
Sat, 26 Sep 2015 17:27:50 +0000 (13:27 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sat, 26 Sep 2015 17:28:26 +0000 (13:28 -0400)
setuptools preserves these permissions when installing them.

Bug: https://bugs.gentoo.org/561546

Package-Manager: portage-2.2.21_p119

net-misc/pycnb/pycnb-0.0.4-r1.ebuild [moved from net-misc/pycnb/pycnb-0.0.4.ebuild with 80% similarity]

similarity index 80%
rename from net-misc/pycnb/pycnb-0.0.4.ebuild
rename to net-misc/pycnb/pycnb-0.0.4-r1.ebuild
index f363f1ae810a701666a0975ba542adf7ea1aa494..c6468e436465ffaf3bca608f6969c6f1707c70a5 100644 (file)
@@ -20,3 +20,9 @@ DEPEND="dev-python/cement[${PYTHON_USEDEP}]
        dev-python/twisted-web
        dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND="${DEPEND}"
+
+src_unpack() {
+       default
+       find ${P} -type d -exec chmod 0755 {} + || die
+       find ${P} -type f -exec chmod 0644 {} + || die
+}