www-apps/icingaweb2-module-pnp4nagios: adding pnp4nagios module
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 5 Oct 2015 21:53:10 +0000 (16:53 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 5 Oct 2015 21:53:10 +0000 (16:53 -0500)
Package-Manager: portage-2.2.20.1

www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild [new file with mode: 0644]
www-apps/icingaweb2-module-pnp4nagios/metadata.xml [new file with mode: 0644]

diff --git a/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
new file mode 100644 (file)
index 0000000..4bcaa4f
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit git-2
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-pnp4nagios.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS=""
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+       >=www-apps/icingaweb2-2.0.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+       mkdir -p "${D}/usr/share/icingaweb2/modules/${PN}"
+       cp -R "${S}"/* "${D}/usr/share/icingaweb2/modules/${PN}"
+}
diff --git a/www-apps/icingaweb2-module-pnp4nagios/metadata.xml b/www-apps/icingaweb2-module-pnp4nagios/metadata.xml
new file mode 100644 (file)
index 0000000..d5dfd32
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <longdescription lang="en">
+       </longdescription>
+</pkgmetadata>