net-misc/netkit-telnetd: Fix 'sed' delimiter
authorPPed72 <paolo.pedroni@iol.it>
Tue, 24 Mar 2020 15:08:11 +0000 (16:08 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 26 Mar 2020 14:00:46 +0000 (16:00 +0200)
Also fixes copyright date and attribution

Closes: https://bugs.gentoo.org/711050
Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it>
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Closes: https://github.com/gentoo/gentoo/pull/15086
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-misc/netkit-telnetd/netkit-telnetd-0.17-r12.ebuild

index e041e858c76c50a22f4453fe80296549dbbc2db5..4c17078b18ae021eac37f6780e464e0444afcb81 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -46,7 +46,7 @@ src_prepare() {
 
        # Fix portability issues.
        sed -i \
-               -e 's:echo -n:printf %s:' \
+               -e 's/echo -n/printf %s/' \
                configure || die
        default
 }
@@ -58,9 +58,9 @@ src_configure() {
        ./configure --prefix=/usr || die
 
        sed -i \
-               -e "s:-pipe -O2:${CFLAGS}:" \
-               -e "s:^\(LDFLAGS=\).*:\1${LDFLAGS}:" \
-               -e "s:-Wpointer-arith::" \
+               -e "s/-pipe -O2/${CFLAGS}/" \
+               -e "s/^\(LDFLAGS=\).*/\1${LDFLAGS}/" \
+               -e "s/-Wpointer-arith//" \
                MCONFIG || die
 }