app-office/libreoffice: Drop USE mysql in >=6.2
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 20 Jan 2019 19:30:48 +0000 (20:30 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 20 Jan 2019 19:31:18 +0000 (20:31 +0100)
There is apparently no way to switch it off at this point.

Closes: https://bugs.gentoo.org/666684
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-office/libreoffice/libreoffice-6.2.9999.ebuild
app-office/libreoffice/libreoffice-9999.ebuild

index dbeed62a746f0abeb19e333c3b645ca1cbc84208..c7a98fa7f09641f2da4cc3ac39aad2aae97d2ed2 100644 (file)
@@ -63,7 +63,7 @@ unset ADDONS_SRC
 LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
 
 IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
-googledrive gstreamer +gtk gtk2 kde mysql odk pdfimport postgres test vlc
+googledrive gstreamer +gtk gtk2 kde odk pdfimport postgres test vlc
 $(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -102,6 +102,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
        app-text/mythes
        >=dev-cpp/clucene-2.3.3.4-r2
        =dev-cpp/libcmis-0.5*
+       dev-db/mysql-connector-c
        dev-db/unixODBC
        dev-lang/perl
        dev-libs/boost:=[nls]
@@ -187,7 +188,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
        )
        libreoffice_extensions_scripting-beanshell? ( dev-java/bsh )
        libreoffice_extensions_scripting-javascript? ( dev-java/rhino:1.6 )
-       mysql? ( dev-db/mysql-connector-c )
        pdfimport? ( app-text/poppler:=[cxx] )
        postgres? ( >=dev-db/postgresql-9.0:*[kerberos] )
 "
@@ -440,7 +440,6 @@ src_configure() {
                $(use_enable gtk2 gtk)
                $(use_enable kde kde5)
                $(use_enable kde qt5)
-               $(use_enable mysql bundle-mariadb)
                $(use_enable odk)
                $(use_enable pdfimport)
                $(use_enable postgres postgresql-sdbc)
index b75bd717a2508b3c5cf66cccbb6628b79c336549..c7a98fa7f09641f2da4cc3ac39aad2aae97d2ed2 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -63,7 +63,7 @@ unset ADDONS_SRC
 LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
 
 IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
-googledrive gstreamer +gtk gtk2 kde mysql odk pdfimport postgres test vlc
+googledrive gstreamer +gtk gtk2 kde odk pdfimport postgres test vlc
 $(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -102,6 +102,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
        app-text/mythes
        >=dev-cpp/clucene-2.3.3.4-r2
        =dev-cpp/libcmis-0.5*
+       dev-db/mysql-connector-c
        dev-db/unixODBC
        dev-lang/perl
        dev-libs/boost:=[nls]
@@ -187,7 +188,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
        )
        libreoffice_extensions_scripting-beanshell? ( dev-java/bsh )
        libreoffice_extensions_scripting-javascript? ( dev-java/rhino:1.6 )
-       mysql? ( dev-db/mysql-connector-c )
        pdfimport? ( app-text/poppler:=[cxx] )
        postgres? ( >=dev-db/postgresql-9.0:*[kerberos] )
 "
@@ -440,7 +440,6 @@ src_configure() {
                $(use_enable gtk2 gtk)
                $(use_enable kde kde5)
                $(use_enable kde qt5)
-               $(use_enable mysql bundle-mariadb)
                $(use_enable odk)
                $(use_enable pdfimport)
                $(use_enable postgres postgresql-sdbc)