dev-util/vulkan-headers: version bump to 1.2.133
authorGuilherme Amadio <amadio@gentoo.org>
Tue, 11 Feb 2020 21:01:27 +0000 (22:01 +0100)
committerGuilherme Amadio <amadio@gentoo.org>
Thu, 5 Mar 2020 07:18:01 +0000 (08:18 +0100)
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Acked-by: Nick Sarnie <sarnex@gentoo.org>
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
dev-util/vulkan-headers/Manifest
dev-util/vulkan-headers/vulkan-headers-1.2.133.ebuild [new file with mode: 0644]

index 9a344fb344bb1493196bb18e77ab373e2946d364..612e7aa31ee7a5c49c49e0b8af4f639c87b0b2cd 100644 (file)
@@ -1 +1,2 @@
 DIST vulkan-headers-1.1.125.tar.gz 662594 BLAKE2B 7cd18b74ff804ed02df3378485f0783332bd09bf898769c48ded20f7a6495b5208cfae3616de401e17ffcec30421b48222520dcd90b03ad83b548405fd8a656c SHA512 355df13347aaa3b32ad62185810c20d1b2f358525d9d8036f6bc7643e7505a25c087a51e05fa7b0758e4ee63221bb39d01d6e14bfb7f99a53cb2127ca5db5d67
+DIST vulkan-headers-1.2.133.tar.gz 713107 BLAKE2B a29272618d224195d38e13d40ca22ee4822e38f5c7b72d3dc02130ccc6a053e05b955993ec4842486f444d819a7f4a6af0690b5c925e6194f254cc196d024cf2 SHA512 9a8375e2634f55bc50653d530db774d39833ca0e9221f6a50667567b254e7334398cb8c0318cb1342b720f223b795933c546cab3cb433443dfbf2a9702700a4f
diff --git a/dev-util/vulkan-headers/vulkan-headers-1.2.133.ebuild b/dev-util/vulkan-headers/vulkan-headers-1.2.133.ebuild
new file mode 100644 (file)
index 0000000..a6116b5
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+       EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Headers.git"
+       inherit git-r3
+else
+       if [[ -z ${SNAPSHOT_COMMIT} ]]; then
+               MY_PV=v${PV}
+               MY_P=Vulkan-Headers-${PV}
+       else
+               MY_PV=${SNAPSHOT_COMMIT}
+               MY_P=Vulkan-Headers-${SNAPSHOT_COMMIT}
+       fi
+       KEYWORDS="~amd64 ~ppc64 ~x86"
+       SRC_URI="https://github.com/KhronosGroup/Vulkan-Headers/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}"/${MY_P}
+fi
+
+RDEPEND="!<dev-util/vulkan-tools-${PV}
+        !<media-libs/vulkan-layers-${PV}"
+
+DESCRIPTION="Vulkan Header files and API registry"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers"
+
+LICENSE="Apache-2.0"
+SLOT="0"