dev-python/PyUtilib: Remove redundant
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:45:00 +0000 (11:45 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:45:00 +0000 (11:45 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/PyUtilib/Manifest
dev-python/PyUtilib/PyUtilib-5.6.5.ebuild [deleted file]

index 7920e7a33a59c40ad934ad65cf3826ab7a08c9bb..728046d1d580dc41ba88130f5f679af0a791840f 100644 (file)
@@ -1,2 +1 @@
-DIST PyUtilib-5.6.5.tar.gz 1504220 BLAKE2B 2d00b8b9a0a787413dce5dd4380382efa4c8788e9a8f5188eb0decf9e55bc07ce5ceb8e6f32ed2fa7cf58c331fe936ea07d9b599ff8e7e9593327d3c0f05d4e9 SHA512 5e7f86c29ff81cfffea5862d09ec8d026739f09b172606acd4d08dc4a9bde28c8b63b8e51634d17c3161b46e7e8c8881050044baa22bc07b0926efe46ed7331d
 DIST PyUtilib-5.7.2.tar.gz 1566034 BLAKE2B 913c6576b39f14c19e2e633c36ade33fe812c77a37374c7c14d2fb4384ca38f68efd55209d70e96d9a78fea2fcf1cf83423680d0787da2d03cab88e59a208b96 SHA512 d9d7d890cdb524bb055885354784f2af01967164ce88cf3b144ccffb0a855ef34243fd518c58193517ecfc50f3c2e3ca333f026951c1ab0b38ce181ecf9e7750
diff --git a/dev-python/PyUtilib/PyUtilib-5.6.5.ebuild b/dev-python/PyUtilib/PyUtilib-5.6.5.ebuild
deleted file mode 100644 (file)
index 32506e7..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="A collection of Python utilities"
-HOMEPAGE="https://github.com/PyUtilib/pyutilib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/six[${PYTHON_USEDEP}]
-       )"
-
-PATCHES=(
-       "${FILESDIR}/pyutilib-5.6.5-tests.patch"
-)
-
-python_prepare() {
-       # shells out to run nosetests
-       rm pyutilib/dev/tests/test_runtests.py || die
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       find "${ED}" -name '*.pth' -delete || die
-}
-
-python_install() {
-       distutils-r1_python_install
-
-       if ! python_is_python3; then
-               printf "# Placeholder for python2\n" \
-                       > "${D}$(python_get_sitedir)/${PN,,}/__init__.py"
-       fi
-}
-
-python_test() {
-       COLUMNS="80" "${EPYTHON}" -W ignore::DeprecationWarning \
-               -m unittest discover -v || die
-}