dev-perl/DBD-MariaDB: Add w/ version 1.210.0 re bug #669624
authorKent Fredric <kentnl@gentoo.org>
Wed, 10 Jul 2019 13:19:52 +0000 (01:19 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 10 Jul 2019 13:20:20 +0000 (01:20 +1200)
By request of Kerin Millar

Closes: https://bugs.gentoo.org/669624
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0.ebuild [new file with mode: 0644]
dev-perl/DBD-MariaDB/Manifest [new file with mode: 0644]
dev-perl/DBD-MariaDB/metadata.xml [new file with mode: 0644]

diff --git a/dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0.ebuild b/dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0.ebuild
new file mode 100644 (file)
index 0000000..f87dcb3
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PALI
+DIST_VERSION=1.21
+inherit perl-module
+
+DESCRIPTION="MariaDB and MySQL driver for the Perl5 Database Interface (DBI)"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test +mariadb mysql minimal"
+REQUIRED_USE="^^ ( mysql mariadb )"
+
+RDEPEND="
+       >=dev-perl/DBI-1.608.0
+       virtual/perl-XSLoader
+       mysql? ( dev-db/mysql-connector-c:0= )
+       mariadb? ( dev-db/mariadb-connector-c:0= )
+"
+# New test-harness needed for parallel testing to work
+DEPEND="${RDEPEND}
+       virtual/perl-Data-Dumper
+       >=dev-perl/Devel-CheckLib-1.120.0
+       virtual/perl-ExtUtils-MakeMaker
+       virtual/perl-File-Spec
+       virtual/perl-Getopt-Long
+       test? (
+               !minimal? (
+                       >=dev-perl/Net-SSLeay-1.430.0
+                       dev-perl/Proc-ProcessTable
+                       virtual/perl-Storable
+               )
+               virtual/perl-Encode
+               virtual/perl-File-Temp
+               dev-perl/Test-Deep
+               >=virtual/perl-Test-Harness-3.310.0
+               >=virtual/perl-Test-Simple-0.900.0
+               virtual/perl-Time-HiRes
+               virtual/perl-bignum
+       )
+"
+PERL_RM_FILES=(
+       "t/pod.t"
+       "t/manifest.t"
+)
+
+src_configure() {
+
+       if use test; then
+               myconf="${myconf} --testdb=test \
+                       --testhost=localhost \
+                       --testuser=test \
+                       --testpassword=test"
+       fi
+       if use mysql; then
+               myconf+=" --mysql_config=${EROOT}usr/bin/mysql_config"
+       fi
+       if use mariadb; then
+               myconf+=" --mariadb_config=${EROOT}usr/bin/mariadb_config"
+       fi
+       perl-module_src_configure
+}
+
+src_test() {
+       einfo
+       einfo "If tests fail, you have to configure your MariaDB/MySQL instance"
+       einfo "to create and grant some privileges to the test user."
+       einfo "You can run the following commands at the MariaDB/MySQL prompt: "
+       einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
+       einfo "> CREATE DATABASE test;"
+       einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
+       einfo
+       sleep 5
+       # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
+       # out why 60leaks.t fails
+       perl-module_src_test
+}
diff --git a/dev-perl/DBD-MariaDB/Manifest b/dev-perl/DBD-MariaDB/Manifest
new file mode 100644 (file)
index 0000000..37da760
--- /dev/null
@@ -0,0 +1 @@
+DIST DBD-MariaDB-1.21.tar.gz 179911 BLAKE2B dac1a868d64e792dc86ab46cea1fe2578ae691b9d6713cd83971c9ba0a3e2a0d8031c7be10dc66e4269c142aec1c54859e0e285faf9a29dc3cec7e3d8ad82a0e SHA512 0378b33e9cd31ced6f2331967c7ea63a233340bb4a60ef2bbece4843b3a62624875aa1a5e61a9fa1b709ecc8d67810c6fa4fb9ccc01df341e6d94325078f360a
diff --git a/dev-perl/DBD-MariaDB/metadata.xml b/dev-perl/DBD-MariaDB/metadata.xml
new file mode 100644 (file)
index 0000000..2d5dd48
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>perl@gentoo.org</email>
+    <name>Gentoo Perl Project</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="cpan">DBD-MariaDB</remote-id>
+    <remote-id type="cpan-module">DBD::MariaDB</remote-id>
+  </upstream>
+  <use>
+    <flag name="mariadb">Use <pkg>dev-db/mariadb-connector-c</pkg> as the client library</flag>
+    <flag name="mysql">Use <pkg>dev-db/mysql-connector-c</pkg> as the client library</flag>
+  </use>
+</pkgmetadata>