app-admin/terraform: 0.12.24 general cleanups
authorWilliam Hubbs <williamh@gentoo.org>
Sat, 21 Mar 2020 21:54:34 +0000 (16:54 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Sat, 21 Mar 2020 21:54:34 +0000 (16:54 -0500)
-drop the use of golang-base
- clean up src_prepare since it was all comments

Signed-off-by: William Hubbs <williamh@gentoo.org>
app-admin/terraform/terraform-0.12.24.ebuild

index 02737dda10ce202e4732e8dd33ddade2bcdedae8..3fd839630186193340de39ad2dcf17c2a6568238 100644 (file)
@@ -3,12 +3,10 @@
 
 EAPI=7
 
-inherit golang-base go-module
+inherit go-module
 
 DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
 HOMEPAGE="https://www.terraform.io/"
-
-EGO_PN="github.com/hashicorp/${PN}"
 SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
@@ -19,17 +17,8 @@ RESTRICT="test"
 
 DOCS=( {README,CHANGELOG}.md )
 
-src_prepare() {
-       default
-       # the sed command is necessary to generate tests outside of the
-       # default git root of `terraform', in our case the working dir
-       # is `work/$PN-$PV'
-       # sed -i -e "s/!=\s\+\"terraform\"/!=\ \"${P}\"/" \
-       #       ./scripts/generate-plugins.go || die
-}
-
 src_compile() {
-       GOCACHE="${T}/go-cache" go build \
+       go build \
                -mod vendor \
                -work -o "bin/${PN}" ./ || die
 }