Version bump. Removed old version.
authorTorsten Veller <tove@gentoo.org>
Sun, 3 Dec 2006 14:35:18 +0000 (14:35 +0000)
committerTorsten Veller <tove@gentoo.org>
Sun, 3 Dec 2006 14:35:18 +0000 (14:35 +0000)
Package-Manager: portage-2.1.2_rc2-r3

mail-filter/bogofilter/ChangeLog
mail-filter/bogofilter/bogofilter-1.1.3.ebuild [new file with mode: 0644]
mail-filter/bogofilter/files/digest-bogofilter-1.1.3 [new file with mode: 0644]

index be34efd3a88ea85401ce745f90f638cb9dd2ed2d..1aa0344a27142076eb87ac8180739ca364c296b7 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for mail-filter/bogofilter
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.74 2006/12/02 09:32:21 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.75 2006/12/03 14:35:18 tove Exp $
+
+*bogofilter-1.1.3 (03 Dec 2006)
+
+  03 Dec 2006; Torsten Veller <tove@gentoo.org> -bogofilter-1.1.1.ebuild,
+  +bogofilter-1.1.3.ebuild:
+  Version bump. Removed old version.
 
   02 Dec 2006; Torsten Veller <tove@gentoo.org> -bogofilter-1.0.2.ebuild,
   -bogofilter-1.0.3.ebuild, bogofilter-1.1.1-r1.ebuild:
diff --git a/mail-filter/bogofilter/bogofilter-1.1.3.ebuild b/mail-filter/bogofilter/bogofilter-1.1.3.ebuild
new file mode 100644 (file)
index 0000000..e821450
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.1.3.ebuild,v 1.1 2006/12/03 14:35:18 tove Exp $
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bogofilter/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gsl berkdb sqlite"
+
+DEPEND="virtual/libiconv
+       berkdb?  ( >=sys-libs/db-3.2 )
+       !berkdb? (
+               sqlite?  ( >=dev-db/sqlite-3.2.6 )
+               !sqlite? ( >=sys-libs/db-3.2 ) )
+       gsl? ( sci-libs/gsl )
+       >=sys-devel/flex-2.5.33"
+#      app-arch/pax" # only needed for bf_tar
+
+src_compile() {
+       local myconf=""
+       myconf="$(use_with !gsl included-gsl)"
+
+       # determine backend: berkdb *is* default
+       if use berkdb && use sqlite ; then
+               einfo "Both berkdb and sqlite are in USE."
+               einfo "Choosing berkdb as default database backend."
+       elif use sqlite ; then
+               myconf="${myconf} --with-database=sqlite"
+       elif ! use berkdb ; then
+               einfo "Using berkdb as database backend."
+       fi
+
+       econf ${myconf} || die "configure failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+
+       exeinto /usr/share/${PN}/contrib
+       doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+               contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+               contrib/{spamitarium,stripsearch}.pl || die "doexec failed"
+
+       insinto /usr/share/${PN}/contrib
+       doins contrib/{README.*,dot-qmail-bogofilter-default} \
+               contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+               contrib/vm-bogofilter.el \
+               contrib/{trainbogo,scramble}.sh || die "doins failed"
+
+       dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+               doc/integrating-with-* doc/README.{db,sqlite} || die "dodoc failed"
+
+       dohtml doc/*.html
+
+       dodir /usr/share/doc/${PF}/samples
+       mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/
+       rmdir "${D}"/etc
+}
+
+pkg_postinst() {
+       echo
+       einfo "If you need ${ROOT}usr/bin/bf_tar please install app-arch/pax."
+       echo
+}
diff --git a/mail-filter/bogofilter/files/digest-bogofilter-1.1.3 b/mail-filter/bogofilter/files/digest-bogofilter-1.1.3
new file mode 100644 (file)
index 0000000..d3fee1c
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 fbd5def47ecde7eafd6c458e7e4cf374 bogofilter-1.1.3.tar.bz2 798238
+RMD160 78b778d3437e6bebaac0502e2e23166b87a1c2e4 bogofilter-1.1.3.tar.bz2 798238
+SHA256 7219d5d2949fc7a956cf9a31fc84d085138c167634f846239488d1f518f12955 bogofilter-1.1.3.tar.bz2 798238