app-arch/cpio: Security bump to version 2.13
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 6 Nov 2019 15:47:51 +0000 (16:47 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 6 Nov 2019 15:47:51 +0000 (16:47 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-arch/cpio/Manifest
app-arch/cpio/cpio-2.13.ebuild [new file with mode: 0644]

index 82a7c3443d1c6d7f7ab733d9483e40967a2dfd4f..e3d8f9e77f92349ae98f9dbca2a88a6c5988770c 100644 (file)
@@ -1 +1,2 @@
 DIST cpio-2.12.tar.bz2 1258605 BLAKE2B 4b6d42a1d8aaeaa980cab5894b2e264451e96a108f2c3aa89d3e6fde0bff338e026ee233ebd7c8cf41f3c926d42d38b866778244db774055736ca8792889e160 SHA512 0cd4da5f2fbca179ab4e666a5f878414c086a5f98bce4c76273f21d9b2a6fe422d901b5d453826c5f81bbe363aa015047a1e99779ad1a451c8feca6205c63120
+DIST cpio-2.13.tar.bz2 1354559 BLAKE2B 45d77723acb55f15c8574ab5a2fdff6fb1767629d177dd3416b0268e9f82ee6bdd11b4fa591ef020efccbdc3f4918cf77263169da1a0f6422dfe1a9712295778 SHA512 459398e69f7f48201c04d1080218c50f75edcf114ffcbb236644ff6fcade5fcc566929bdab2ebe9be5314828d6902e43b348a8adf28351df978c8989590e93a3
diff --git a/app-arch/cpio/cpio-2.13.ebuild b/app-arch/cpio/cpio-2.13.ebuild
new file mode 100644 (file)
index 0000000..d953e62
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A file archival tool which can also read and write tar files"
+HOMEPAGE="https://www.gnu.org/software/cpio/cpio.html"
+SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.12-non-gnu-compilers.patch #275295
+)
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable nls)
+               --bindir="${EPREFIX}"/bin
+               --with-rmt="${EPREFIX}"/usr/sbin/rmt
+       )
+       econf "${myeconfargs[@]}"
+}