New release: 1.1.20
authorLeonardo Boshell <leonardop@gentoo.org>
Thu, 18 Jan 2007 03:05:30 +0000 (03:05 +0000)
committerLeonardo Boshell <leonardop@gentoo.org>
Thu, 18 Jan 2007 03:05:30 +0000 (03:05 +0000)
Package-Manager: portage-2.1.1-r2

dev-libs/libxslt/ChangeLog
dev-libs/libxslt/files/digest-libxslt-1.1.20 [new file with mode: 0644]
dev-libs/libxslt/libxslt-1.1.20.ebuild [new file with mode: 0644]

index 7e1d30c134445688777270a2773fbe44a587d300..a03eb04ffc08eb6285c9304bd1afcf3d22d21cde 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-libs/libxslt
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.145 2006/12/21 07:59:45 robbat2 Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.146 2007/01/18 03:05:30 leonardop Exp $
+
+*libxslt-1.1.20 (18 Jan 2007)
+
+  18 Jan 2007; Leonardo Boshell <leonardop@gentoo.org>
+  -libxslt-1.1.19.ebuild, +libxslt-1.1.20.ebuild:
+  New release. Removing 1.1.19 because of some important bugs it had,
+  including bug #159318.
 
   21 Dec 2006; Robin H. Johnson <robbat2@gentoo.org> libxslt-1.1.19.ebuild:
   Fix libxml DEP.
diff --git a/dev-libs/libxslt/files/digest-libxslt-1.1.20 b/dev-libs/libxslt/files/digest-libxslt-1.1.20
new file mode 100644 (file)
index 0000000..5432130
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 4ea2dc22a23bf2aa570f868aa86357f8 libxslt-1.1.20.tar.gz 3689759
+RMD160 f2882ff47312de3b6317136ef751d4b42ab15a53 libxslt-1.1.20.tar.gz 3689759
+SHA256 ce92f00031c885e04cb65ea76c4675b07aa98af9607572fb0d68180c34bf5346 libxslt-1.1.20.tar.gz 3689759
diff --git a/dev-libs/libxslt/libxslt-1.1.20.ebuild b/dev-libs/libxslt/libxslt-1.1.20.ebuild
new file mode 100644 (file)
index 0000000..b41e8c2
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.20.ebuild,v 1.1 2007/01/18 03:05:30 leonardop Exp $
+
+inherit libtool eutils python
+
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="crypt debug python"
+
+DEPEND=">=dev-libs/libxml2-2.6.27
+       crypt? ( >=dev-libs/libgcrypt-1.1.92 )
+       python? ( dev-lang/python )"
+
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz"
+
+
+src_unpack() {
+       unpack "${A}"
+       cd "${S}"
+
+       # we still require the 1.1.8 patch for the .m4 file, to add
+       # the CXXFLAGS defines <obz@gentoo.org>
+       epatch "${FILESDIR}"/libxslt.m4-${PN}-1.1.8.patch
+
+       # Patch Makefile to fix bug #99382 so that html gets installed in ${PF}
+       sed -i -e 's:libxslt-$(VERSION):${PF}:' doc/Makefile.in
+
+       epunt_cxx
+       elibtoolize
+}
+
+src_compile() {
+       # Always pass --with-debugger. It is required by third parties (see
+       # e.g. bug #98345)
+       local myconf="--with-debugger \
+               $(use_with python)       \
+               $(use_with crypt crypto) \
+               $(use_with debug)        \
+               $(use_with debug mem-debug)"
+
+       econf ${myconf} || die "configure failed"
+
+       # Patching the Makefiles to respect get_libdir
+       # Fixes BUG #86756, please keep this.
+       # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+       for x in $(find "${S}" -name "Makefile") ; do
+               sed \
+                       -e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
+                       -i ${x} \
+                       || die "sed failed"
+       done
+
+       emake || die "Compilation failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "Installation failed"
+
+       dodoc AUTHORS ChangeLog Copyright FEATURES NEWS README TODO
+}