Initial commit
authorLina Pezzella <j4rg0n@gentoo.org>
Thu, 20 Jan 2005 00:34:38 +0000 (00:34 +0000)
committerLina Pezzella <j4rg0n@gentoo.org>
Thu, 20 Jan 2005 00:34:38 +0000 (00:34 +0000)
sci-biology/MrBayes/ChangeLog [new file with mode: 0644]
sci-biology/MrBayes/Manifest [new file with mode: 0644]
sci-biology/MrBayes/MrBayes-3.0.ebuild [new file with mode: 0644]
sci-biology/MrBayes/files/digest-MrBayes-3.0 [new file with mode: 0644]
sci-biology/MrBayes/metadata.xml [new file with mode: 0644]

diff --git a/sci-biology/MrBayes/ChangeLog b/sci-biology/MrBayes/ChangeLog
new file mode 100644 (file)
index 0000000..0e021ff
--- /dev/null
@@ -0,0 +1,7 @@
+# ChangeLog for sci-biology/MrBayes
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/MrBayes/ChangeLog,v 1.1 2005/01/20 00:34:38 j4rg0n Exp $
+
+  19 Jan 2005; Lina Pezzella <j4rg0n@gentoo.org> :
+  Initial commit
+
diff --git a/sci-biology/MrBayes/Manifest b/sci-biology/MrBayes/Manifest
new file mode 100644 (file)
index 0000000..1e5dd0c
--- /dev/null
@@ -0,0 +1,4 @@
+MD5 964843ec8288ff42335c302b0fa80819 MrBayes-3.0.ebuild 832
+MD5 3fd56e7547b0f35a37db19dd45932fef metadata.xml 792
+MD5 dfb91dda222baec6280d5b3eeb6bc5ad ChangeLog 280
+MD5 98b5d381ba0621a27ffce26bf40da031 files/digest-MrBayes-3.0 64
diff --git a/sci-biology/MrBayes/MrBayes-3.0.ebuild b/sci-biology/MrBayes/MrBayes-3.0.ebuild
new file mode 100644 (file)
index 0000000..44317ed
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/MrBayes/MrBayes-3.0.ebuild,v 1.1 2005/01/20 00:34:38 j4rg0n Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Bayesian Inference of Phylogeny"
+HOMEPAGE="http://morphbank.ebc.uu.se/mrbayes/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc-macos"
+IUSE=""
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       # TODO: Implement MPI-aware ebuild/use flags, etc. to use Makefile-Mpi
+
+       # Fix the non-standard Makefile.
+       sed -i \
+               -e "s:-O4:${CFLAGS}:" \
+               -e "s:gcc:${CC}:" \
+               Makefile
+}
+
+src_compile() {
+       emake \
+               CC="$(tc-getCC)" \
+               CXX="$(tc-getCXX)" \
+               || die "emake failed"
+}
+
+src_install() {
+       # Non-standard manual install
+       into /usr
+       dobin mb
+}
diff --git a/sci-biology/MrBayes/files/digest-MrBayes-3.0 b/sci-biology/MrBayes/files/digest-MrBayes-3.0
new file mode 100644 (file)
index 0000000..f79cf0d
--- /dev/null
@@ -0,0 +1 @@
+MD5 be98da64334732b9b12dde1da2907850 MrBayes-3.0.tar.bz2 300352
diff --git a/sci-biology/MrBayes/metadata.xml b/sci-biology/MrBayes/metadata.xml
new file mode 100644 (file)
index 0000000..eade7f8
--- /dev/null
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-biology</herd>
+<maintainer>
+  <email>j4rg0n@gentoo.org</email>
+</maintainer>
+<longdescription>
+MrBayes is a program for the Bayesian estimation of phylogeny.
+Bayesian inference of phylogeny is based upon a quantity called the
+posterior probability distribution of trees, which is the probability of a
+tree conditioned on the observations. The conditioning is accomplished using
+Bayes's theorem. The posterior probability distribution of trees is
+impossible to calculate analytically; instead, MrBayes uses a simulation
+technique called Markov chain Monte Carlo (or MCMC) to approximate the
+posterior probabilities of trees.
+</longdescription>
+</pkgmetadata>