dev-python/tablib: remove old and vulnerable
authorVirgil Dupras <vdupras@gentoo.org>
Sun, 9 Sep 2018 23:05:22 +0000 (19:05 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Sun, 9 Sep 2018 23:05:22 +0000 (19:05 -0400)
Bug: https://bugs.gentoo.org/621884
Package-Manager: Portage-2.3.49, Repoman-2.3.10

dev-python/tablib/Manifest
dev-python/tablib/tablib-0.11.2.ebuild [deleted file]
dev-python/tablib/tablib-0.12.1.ebuild [deleted file]

index 3a7a9e3c11ebdd16008e1f2d76e6495ec4483cae..dc32b7d2b2a230923041e82a492fea498930974c 100644 (file)
@@ -1,2 +1 @@
-DIST tablib-0.11.2.tar.gz 758287 BLAKE2B 103ffaa755d7066b19243075fc0069fd7fa256e77f21c5a972a2077633e69064bdb433e3784780d2ac5a439aae62fb94dd128af755714de1fcdd5be46e3cb446 SHA512 356bf308df7c3d7d20800814a945c83fc64e98fb859d180cf5d9455ec2634e0a20f0c6ed788a75117c7c3d7bd4cda319c2049ce760109d102b2cb9a0707fa4f2
 DIST tablib-0.12.1.tar.gz 63420 BLAKE2B a4c4b2cd7f54045480fcac41ae55150ed903810de9f97df1a04ae74bdce16cd7c57027d38addbca8230a05ecd591290f2cdfe7736ccb02597a05cf7ffa0f5f4d SHA512 5207f59dab59f465584fc6c55d6322150f550c50f50a35d6901a39ed05a624a52dfdb5a9a9ddf0d6bc7285e5a3a4972c458895e4cc204a365c3df0d9ada0228a
diff --git a/dev-python/tablib/tablib-0.11.2.ebuild b/dev-python/tablib/tablib-0.11.2.ebuild
deleted file mode 100644 (file)
index faa0359..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5}} )
-
-inherit distutils-r1
-
-DESCRIPTION="A format-agnostic tabular dataset library written in Python"
-HOMEPAGE="http://python-tablib.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="
-       dev-python/ujson[${PYTHON_USEDEP}]
-       dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
-       py.test -v -v  || die
-}
diff --git a/dev-python/tablib/tablib-0.12.1.ebuild b/dev-python/tablib/tablib-0.12.1.ebuild
deleted file mode 100644 (file)
index b715f7e..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-
-inherit distutils-r1
-
-DESCRIPTION="A format-agnostic tabular dataset library written in Python"
-HOMEPAGE="http://python-tablib.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
-       dev-python/openpyxl[${PYTHON_USEDEP}]
-       dev-python/pyyaml[${PYTHON_USEDEP}]
-       dev-python/ujson[${PYTHON_USEDEP}]
-       dev-python/xlrd[${PYTHON_USEDEP}]
-       dev-python/xlwt[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_test() {
-       py.test -v -v  || die
-}