dev-perl/WWW-Curl: Add patches by Slaven Rezic, bug 694466
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Thu, 7 Nov 2019 21:10:28 +0000 (22:10 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Thu, 7 Nov 2019 21:11:04 +0000 (22:11 +0100)
Closes: https://bugs.gentoo.org/694466
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
dev-perl/WWW-Curl/WWW-Curl-4.170.0-r1.ebuild
dev-perl/WWW-Curl/files/WWW-Curl-4.17-RT117793.patch [new file with mode: 0644]
dev-perl/WWW-Curl/files/WWW-Curl-4.17-RT130591.patch [new file with mode: 0644]

index f2ce9d9aeaf25f12f4de1dbd521fa87c1729c814..d9eb8c504aba21da800dcc424b307ebd00d167d7 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -21,5 +21,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-4.150.0-curl-7.50.2.patch
        "${FILESDIR}"/${PN}-4.17-dotinc.patch
        "${FILESDIR}"/${PN}-4.17-networktests.patch
+       "${FILESDIR}"/${PN}-4.17-RT117793.patch
+       "${FILESDIR}"/${PN}-4.17-RT130591.patch
 )
 PERL_RM_FILES=("t/meta.t" "t/pod-coverage.t" "t/pod.t")
diff --git a/dev-perl/WWW-Curl/files/WWW-Curl-4.17-RT117793.patch b/dev-perl/WWW-Curl/files/WWW-Curl-4.17-RT117793.patch
new file mode 100644 (file)
index 0000000..e89d237
--- /dev/null
@@ -0,0 +1,25 @@
+From 292c05a8aa9c18bd27d0aaff0b4ee601d9b87b92 Mon Sep 17 00:00:00 2001
+From: Slaven Rezic <cpansand@cvrsnica-freebsd-101.herceg.de>
+Date: Sun, 16 Apr 2017 22:17:00 +0200
+Subject: [PATCH] compilation fixes for curl 7.50.2 and newer (RT #117793)
+
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index f9170bb..bb852e4 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -127,7 +127,7 @@ if (!defined($curl_h)) {
+     close H;
+     for my $e (sort @syms) {
+-       if($e =~ /(OBSOLETE|^CURL_EXTERN|_LAST\z|_LASTENTRY\z)/) {
++       if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|^CURL_DID_MEMORY_FUNC_TYPEDEFS\z|_LAST\z|_LASTENTRY\z)/) {
+           next;
+        }
+        my ($group) = $e =~ m/^([^_]+_)/;
+-- 
+2.1.2
+
diff --git a/dev-perl/WWW-Curl/files/WWW-Curl-4.17-RT130591.patch b/dev-perl/WWW-Curl/files/WWW-Curl-4.17-RT130591.patch
new file mode 100644 (file)
index 0000000..753b3ed
--- /dev/null
@@ -0,0 +1,41 @@
+From 0ef6ea22479b4696a0d62cd44aac8f4fe866db2f Mon Sep 17 00:00:00 2001
+From: Slaven Rezic <cpansand@cloud1.bbbike.org>
+Date: Sun, 29 Sep 2019 16:19:57 +0000
+Subject: [PATCH] compat for libcurl 7.66.0 (fix for RT #130591)
+
+---
+ Curl.xs     | 4 ++++
+ Makefile.PL | 2 +-
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/Curl.xs b/Curl.xs
+index ea9f870..e81c415 100644
+--- a/Curl.xs
++++ b/Curl.xs
+@@ -18,6 +18,10 @@
+ #include <curl/easy.h>
+ #include <curl/multi.h>
++#ifdef CURLINC_MULTI_H
++#define __CURL_MULTI_H
++#endif
++
+ #define header_callback_func writeheader_callback_func
+ /* Do a favor for older perl versions */
+diff --git a/Makefile.PL b/Makefile.PL
+index bb852e4..713656a 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -127,7 +127,7 @@ if (!defined($curl_h)) {
+     close H;
+     for my $e (sort @syms) {
+-       if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|^CURL_DID_MEMORY_FUNC_TYPEDEFS\z|_LAST\z|_LASTENTRY\z)/) {
++       if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|^CURL_DID_MEMORY_FUNC_TYPEDEFS\z|_LAST\z|_LASTENTRY\z|^CURLINC_)/) {
+           next;
+        }
+        my ($group) = $e =~ m/^([^_]+_)/;
+-- 
+2.1.4
+