sys-power/powerstat: version bump to 0.02.20
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>
Sat, 5 Oct 2019 15:59:57 +0000 (18:59 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 6 Oct 2019 17:41:49 +0000 (19:41 +0200)
Closes: https://bugs.gentoo.org/696622
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-power/powerstat/Manifest
sys-power/powerstat/powerstat-0.02.20.ebuild [new file with mode: 0644]

index bb7b366314ddc53449963f0baecef27d26a86ed9..b31e68bedc7213524223c89f4ea31f516e5943d1 100644 (file)
@@ -1 +1,2 @@
 DIST powerstat-0.02.18.tar.gz 59205 BLAKE2B 80230b0571b0920d68ed0148220d0b50c84dece6a24c11d866a885c63da336d5a632119a667a3348dcc8b6f62ed98a5785ad91120a3ee9d98ddd0dbb5952aaea SHA512 2634ae760d2cd68f71d315033d53bcda843b977bfe34190f792a5937a29dc4b6d220b91bd3b538be75394c8ba9b5a8d883e3d99ea8b840abf4106880da7a1404
+DIST powerstat-0.02.20.tar.gz 59127 BLAKE2B 893637b3b2ebb2969dcea34a02ff9c90aa1d08b2bb5fafcb80b6d41520e03b5696acc6020a337afaac676eb29e48e5449f718a40d88535d114766d77f70f6fca SHA512 1bfe33cb06d4647c8552ee4b85e12f55475b3a0aa77aaa9cbd72ba11c9c67bb087d64dbda2b6362fb60440e30060e670eb6ba4b7f164f7ab306320994e54fabe
diff --git a/sys-power/powerstat/powerstat-0.02.20.ebuild b/sys-power/powerstat/powerstat-0.02.20.ebuild
new file mode 100644 (file)
index 0000000..9a3027b
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Laptop power measuring tool"
+HOMEPAGE="https://launchpad.net/ubuntu/+source/powerstat https://github.com/ColinIanKing/powerstat"
+SRC_URI="https://github.com/ColinIanKing/${PN}/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Don't compress manpages
+PATCHES=( "${FILESDIR}"/"${PN}"-0.02.17-makefile.patch )
+
+src_compile() {
+       emake CC="$(tc-getCC)"
+}