app-editors/gvim: version bump to 8.2.0210
authorTim Harder <radhermit@gentoo.org>
Wed, 5 Feb 2020 05:05:08 +0000 (22:05 -0700)
committerTim Harder <radhermit@gentoo.org>
Wed, 5 Feb 2020 05:12:32 +0000 (22:12 -0700)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
app-editors/gvim/Manifest
app-editors/gvim/gvim-8.2.0210.ebuild [new file with mode: 0644]
app-editors/gvim/gvim-9999.ebuild

index 32dd1077491aec302dbc0a35fe170181816534cd..71ed0753222dc70f53616949e92beff849f07371 100644 (file)
@@ -3,3 +3,5 @@ DIST vim-8.1.1486.tar.gz 14318109 BLAKE2B 6054df175a32e9ed36873802a4a669cc46e034
 DIST vim-8.1.1846.tar.gz 14415116 BLAKE2B 59c2864519e100f9bc2617dd7b31a8cc17ff20fc87a761eba653e91a70688c3b4a5f05c527acaf6d075830d23c7ef8842595b6558eac2ab5209029153f1adb10 SHA512 d5a5cb7733f3190915e2b1389fea48d119afef27eac6f04ac3967f57e894cab811727a694c6837bb5acef9997cd56018d4b37efeb413c654012aaaea02bf7c7a
 DIST vim-8.2.0055.tar.gz 14655766 BLAKE2B 73703f4f08cd78f75c53cd446e3edc171805a19bce37bcc4f420f4800d50b515a265ceb885947668e8654666cfca52a189f2abc407d2db0f520a6ceb124e20ec SHA512 ccbf0bb4cd294292ef69c2b7f4539ed87aa3cbdb5e638dbcc3e86b8e3986c96419c033685a7b2293382ace0599457a523e3bf25815882cec74f6ecec87139d92
 DIST vim-8.2.0114.tar.gz 14667122 BLAKE2B 3f6219592a1b8ed85caee4cfa289e4042380da4e4a563692fb36d60fdec9e29930a8e20963fa57dddd4dd346928b34626ea51a8ab79085c1fac86c755bccfeac SHA512 0e45a63bc910f8f2972e2df076523d3a2612836bee0cffba6c2753eeadaff978054689af4029384713e822aabe0e57aa8c89bbb5f9a813781f381c3a2a416d1f
+DIST vim-8.2.0210-gentoo-patches.tar.bz2 2755 BLAKE2B 21f1fb97c95d4f2eb45968783add80e11011be12fd2d701c267644a44da9782214828e022667c1a0a2ed08aedb7c12b6756a8b8adea4db5c7a3cb7dc94b75fd8 SHA512 c942c33dc033d63569e07523fa7652d1c53685aa64f9e7a4bf4e6126012790ec0ec820a7a9209cfe64096679ba8a9f9394ed92696a933e3c8be10658d16b8a7b
+DIST vim-8.2.0210.tar.gz 14757725 BLAKE2B b78ed42b42d40911efb76d4317c116b1c207909ed47241f9dbe6cf6385a4a25ee8cceb2d883171dd922027fb91e9f25e4741fdcd6ebc69217e7d26eae2f88efe SHA512 118131c7c186bac36b3e4928a0021e03b4bf197e1d5651019f4fcf8d4fee89fb7e0123adaf18bebc932c5e06217904526d0625513646e34aebf6cfdee8885260
diff --git a/app-editors/gvim/gvim-8.2.0210.ebuild b/app-editors/gvim/gvim-8.2.0210.ebuild
new file mode 100644 (file)
index 0000000..d67c65f
--- /dev/null
@@ -0,0 +1,367 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VIM_VERSION="8.2"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+inherit vim-doc flag-o-matic xdg-utils bash-completion-r1 prefix python-single-r1 ruby-single
+
+if [[ ${PV} == 9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/vim/vim.git"
+       EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
+else
+       SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
+               https://dev.gentoo.org/~radhermit/vim/vim-8.2.0210-gentoo-patches.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+fi
+
+DESCRIPTION="GUI version of the Vim text editor"
+HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
+
+SLOT="0"
+LICENSE="vim"
+IUSE="acl aqua cscope debug gtk gtk2 lua luajit motif neXt netbeans nls perl python racket ruby selinux session sound tcl"
+REQUIRED_USE="
+       python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+       ~app-editors/vim-core-${PV}
+       >=app-eselect/eselect-vi-1.1
+       >=sys-libs/ncurses-5.2-r2:0=
+       x11-libs/libICE
+       x11-libs/libSM
+       x11-libs/libXext
+       x11-libs/libXt
+       acl? ( kernel_linux? ( sys-apps/acl ) )
+       !aqua? (
+               gtk? (
+                       x11-libs/gtk+:3
+                       x11-libs/libXft
+               )
+               !gtk? (
+                       gtk2? (
+                               >=x11-libs/gtk+-2.6:2
+                               x11-libs/libXft
+                       )
+                       !gtk2? (
+                               motif? ( >=x11-libs/motif-2.3:0 )
+                               !motif? (
+                                       neXt? ( x11-libs/neXtaw )
+                                       !neXt? ( x11-libs/libXaw )
+                               )
+                       )
+               )
+       )
+       cscope? ( dev-util/cscope )
+       lua? (
+               luajit? ( dev-lang/luajit:2= )
+               !luajit? ( dev-lang/lua:0[deprecated] )
+       )
+       nls? ( virtual/libintl )
+       perl? ( dev-lang/perl:= )
+       python? ( ${PYTHON_DEPS} )
+       racket? ( dev-scheme/racket )
+       ruby? ( ${RUBY_DEPS} )
+       selinux? ( sys-libs/libselinux )
+       session? ( x11-libs/libSM )
+       sound? ( media-libs/libcanberra )
+       tcl? ( dev-lang/tcl:0= )
+"
+DEPEND="${RDEPEND}
+       sys-devel/autoconf
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )
+"
+
+# various failures (bugs #630042 and #682320)
+RESTRICT="test"
+
+S=${WORKDIR}/vim-${PV}
+
+pkg_setup() {
+       # people with broken alphabets run into trouble. bug 82186.
+       unset LANG LC_ALL
+       export LC_COLLATE="C"
+
+       # Gnome sandbox silliness. bug #114475.
+       mkdir -p "${T}"/home || die
+       export HOME="${T}"/home
+
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       if [[ ${PV} != 9999* ]]; then
+               # Gentoo patches to fix runtime issues, cross-compile errors, etc
+               eapply "${WORKDIR}"/patches/
+       fi
+
+       # Fixup a script to use awk instead of nawk
+       sed -i -e \
+               '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' \
+               "${S}"/runtime/tools/mve.awk || die "mve.awk sed failed"
+
+       # Read vimrc and gvimrc from /etc/vim
+       echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' \
+           >> "${S}"/src/feature.h || die "echo failed"
+       echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' \
+           >> "${S}"/src/feature.h || die "echo failed"
+
+       # Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
+       # Hopefully this pattern won't break for a while at least.
+       # This fixes bug 29398 (27 Sep 2003 agriffis)
+       sed -i -e \
+               's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
+               "${S}"/runtime/doc/syntax.txt \
+               "${S}"/runtime/doc/tagsrch.txt \
+               "${S}"/runtime/doc/usr_29.txt \
+               "${S}"/runtime/menu.vim \
+               "${S}"/src/configure.ac || die 'sed failed'
+
+       # Don't be fooled by /usr/include/libc.h.  When found, vim thinks
+       # this is NeXT, but it's actually just a file in dev-libs/9libs
+       # This fixes bug 43885 (20 Mar 2004 agriffis)
+       sed -i -e \
+               's/ libc\.h / /' "${S}"/src/configure.ac || die 'sed failed'
+
+       # gcc on sparc32 has this, uhm, interesting problem with detecting EOF
+       # correctly. To avoid some really entertaining error messages about stuff
+       # which isn't even in the source file being invalid, we'll do some trickery
+       # to make the error never occur. bug 66162 (02 October 2004 ciaranm)
+       find "${S}" -name '*.c' | while read c; do
+           echo >> "$c" || die "echo failed"
+       done
+
+       # Try to avoid sandbox problems. Bug #114475.
+       if [[ -d "${S}"/src/po ]]; then
+               sed -i -e \
+                       '/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
+                       "${S}"/src/po/Makefile || die
+       fi
+
+       cp -v "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk || die "cp failed"
+
+       # Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
+       sed -i -e \
+               "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
+               "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
+
+       eapply_user
+}
+
+src_configure() {
+       local myconf=()
+
+       # Fix bug 37354: Disallow -funroll-all-loops on amd64
+       # Bug 57859 suggests that we want to do this for all archs
+       filter-flags -funroll-all-loops
+
+       # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
+       # everyone since previous flag filtering bugs have turned out to affect
+       # multiple archs...
+       replace-flags -O3 -O2
+
+       # Fix bug 18245: Prevent "make" from the following chain:
+       # (1) Notice configure.ac is newer than auto/configure
+       # (2) Rebuild auto/configure
+       # (3) Notice auto/configure is newer than auto/config.mk
+       # (4) Run ./configure (with wrong args) to remake auto/config.mk
+       sed -i -e \
+               's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
+       rm -v src/auto/configure || die "rm failed"
+       emake -j1 -C src autoconf
+
+       # This should fix a sandbox violation (see bug 24447). The hvc
+       # things are for ppc64, see bug 86433.
+       local file
+       for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc*; do
+               if [[ -e ${file} ]]; then
+                       addwrite $file
+               fi
+       done
+
+       use debug && append-flags "-DDEBUG"
+
+       myconf=(
+               --with-features=huge
+               --disable-gpm
+               --with-gnome=no
+               $(use_enable sound canberra)
+               $(use_enable acl)
+               $(use_enable cscope)
+               $(use_enable lua luainterp)
+               $(use_with luajit)
+               $(use_enable netbeans)
+               $(use_enable nls)
+               $(use_enable perl perlinterp)
+               $(use_enable python python3interp dynamic)
+               $(use_with python python3-command $(type -P $(eselect python show --python3)))
+               $(use_enable racket mzschemeinterp)
+               $(use_enable ruby rubyinterp)
+               $(use_enable selinux)
+               $(use_enable session xsmp)
+               $(use_enable tcl tclinterp)
+       )
+
+       # --with-features=huge forces on cscope even if we --disable it. We need
+       # to sed this out to avoid screwiness. (1 Sep 2004 ciaranm)
+       if ! use cscope; then
+               sed -i -e \
+                       '/# define FEAT_CSCOPE/d' src/feature.h || die "couldn't disable cscope"
+       fi
+
+       # gvim's GUI preference order is as follows:
+       # aqua                         CARBON (not tested)
+       # -aqua gtk                    GTK3
+       # -aqua -gtk gtk2              GTK2
+       # -aqua -gtk -gtk motif        MOTIF
+       # -aqua -gtk -gtk -motif neXt  NEXTAW
+       # -aqua -gtk -gtk -motif -neXt ATHENA
+       echo ; echo
+       if use aqua; then
+               einfo "Building gvim with the Carbon GUI"
+               myconf+=(
+                       --enable-darwin
+                       --enable-gui=carbon
+               )
+       elif use gtk; then
+               myconf+=( --enable-gtk3-check )
+               einfo "Building gvim with the gtk+-3 GUI"
+               myconf+=( --enable-gui=gtk3 )
+       elif use gtk2; then
+               myconf+=( --enable-gtk2-check )
+               einfo "Building gvim with the gtk+-2 GUI"
+               myconf+=( --enable-gui=gtk2 )
+       elif use motif; then
+               einfo "Building gvim with the MOTIF GUI"
+               myconf+=( --enable-gui=motif )
+       elif use neXt; then
+               einfo "Building gvim with the neXtaw GUI"
+               myconf+=( --enable-gui=nextaw )
+       else
+               einfo "Building gvim with the Athena GUI"
+               myconf+=( --enable-gui=athena )
+       fi
+       echo ; echo
+
+       # let package manager strip binaries
+       export ac_cv_prog_STRIP="$(type -P true ) faking strip"
+
+       # keep prefix env contained within the EPREFIX
+       use prefix && myconf+=( --without-local-dir )
+
+       if [[ ${CHOST} == *-interix* ]]; then
+               # avoid finding of this function, to avoid having to patch either
+               # configure or the source, which would be much more hackish.
+               # after all vim does it right, only interix is badly broken (again)
+               export ac_cv_func_sigaction=no
+       fi
+
+       econf \
+               --with-modified-by=Gentoo-${PVR} \
+               --with-vim-name=gvim \
+               --with-x \
+               "${myconf[@]}"
+}
+
+src_compile() {
+       # The following allows emake to be used
+       emake -j1 -C src auto/osdef.h objects
+
+       emake
+}
+
+src_test() {
+       einfo
+       einfo "Starting vim tests. Several error messages will be shown"
+       einfo "while the tests run. This is normal behaviour and does not"
+       einfo "indicate a fault."
+       einfo
+       ewarn "If the tests fail, your terminal may be left in a strange"
+       ewarn "state. Usually, running 'reset' will fix this."
+       einfo
+
+       # Don't let vim talk to X
+       unset DISPLAY
+
+       # Make gvim not try to connect to X. See :help gui-x11-start in vim for how
+       # this evil trickery works.
+       ln -s "${S}"/src/gvim "${S}"/src/testvim || die
+
+       # Make sure our VIMPROG is used.
+       sed -i -e 's:\.\./vim:../testvim:' src/testdir/test49.vim || die
+
+       # Don't do additional GUI tests.
+       emake -j1 VIMPROG=../testvim -C src/testdir nongui
+}
+
+# Call eselect vi update with --if-unset
+# to respect user's choice (bug 187449)
+eselect_vi_update() {
+       einfo "Calling eselect vi update..."
+       eselect vi update --if-unset
+       eend $?
+}
+
+src_install() {
+       local vimfiles=/usr/share/vim/vim${VIM_VERSION/.}
+
+       dobin src/gvim
+       dosym gvim /usr/bin/gvimdiff
+       dosym gvim /usr/bin/evim
+       dosym gvim /usr/bin/eview
+       dosym gvim /usr/bin/gview
+       dosym gvim /usr/bin/rgvim
+       dosym gvim /usr/bin/rgview
+
+       emake -C src DESTDIR="${D}" DATADIR="${EPREFIX}"/usr/share install-icons
+
+       dodir /usr/share/man/man1
+       echo ".so vim.1" > "${ED}"/usr/share/man/man1/gvim.1 || die "echo failed"
+       echo ".so vim.1" > "${ED}"/usr/share/man/man1/gview.1 || die "echo failed"
+       echo ".so vimdiff.1" > "${ED}"/usr/share/man/man1/gvimdiff.1 || \
+               die "echo failed"
+
+       insinto /etc/vim
+       newins "${FILESDIR}"/gvimrc-r1 gvimrc
+       eprefixify "${ED}"/etc/vim/gvimrc
+
+       # bash completion script, bug #79018.
+       newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
+
+       # don't install vim desktop file
+       rm -v "${ED}"/usr/share/applications/vim.desktop || die "failed to remove vim.desktop"
+}
+
+pkg_postinst() {
+       # update documentation tags (from vim-doc.eclass)
+       update_vim_helptags
+
+       # update fdo mime stuff, bug #78394
+       xdg_desktop_database_update
+
+       # update icon cache
+       xdg_icon_cache_update
+
+       # call eselect vi update
+       eselect_vi_update
+}
+
+pkg_postrm() {
+       # update documentation tags (from vim-doc.eclass)
+       update_vim_helptags
+
+       # update fdo mime stuff, bug #78394
+       xdg_desktop_database_update
+
+       # update icon cache
+       xdg_icon_cache_update
+
+       # call eselect vi update
+       eselect_vi_update
+}
index 2bdfc5eb23487a624c228607ddb897a48ad600d7..d67c65f8ee9b2fabd3790f05db0435a38c99e15f 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 VIM_VERSION="8.2"
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="threads(+)"
 USE_RUBY="ruby24 ruby25 ruby26 ruby27"
 
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999* ]]; then
        EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
 else
        SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
-               https://dev.gentoo.org/~radhermit/vim/vim-8.0.0938-gentoo-patches.tar.bz2"
+               https://dev.gentoo.org/~radhermit/vim/vim-8.2.0210-gentoo-patches.tar.bz2"
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
 fi
 
@@ -199,7 +199,7 @@ src_configure() {
                $(use_enable netbeans)
                $(use_enable nls)
                $(use_enable perl perlinterp)
-               $(use_enable python python3interp)
+               $(use_enable python python3interp dynamic)
                $(use_with python python3-command $(type -P $(eselect python show --python3)))
                $(use_enable racket mzschemeinterp)
                $(use_enable ruby rubyinterp)