sys-libs/ncurses: avoid building tests when unused
authorMike Frysinger <vapier@gentoo.org>
Wed, 12 Aug 2015 10:23:40 +0000 (06:23 -0400)
committerMike Frysinger <vapier@gentoo.org>
Wed, 12 Aug 2015 10:38:09 +0000 (06:38 -0400)
If the user isn't going to run the testsuite, there's no point in building
all the test binaries, so put that logic behind the standard USE=test.

sys-libs/ncurses/ncurses-6.0.ebuild

index 7372e09a5895f04434670b943db57b5b6ef03e4f..8a055bf713eac3cc817c6f9c6e36f9bd12ea3ead 100644 (file)
@@ -18,7 +18,7 @@ LICENSE="MIT"
 # The subslot reflects the SONAME.
 SLOT="5/6"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="ada +cxx debug doc gpm minimal profile static-libs tinfo trace unicode"
+IUSE="ada +cxx debug doc gpm minimal profile static-libs test tinfo trace unicode"
 
 DEPEND="gpm? ( sys-libs/gpm[${MULTILIB_USEDEP}] )"
 #      berkdb? ( sys-libs/db )"
@@ -115,6 +115,7 @@ do_configure() {
                $(use_enable !debug leaks)
                $(use_with debug expanded)
                $(use_with !debug macros)
+               $(use_with test tests)
                $(use_with trace)
                $(use_with tinfo termlib)
        )