app-text/po4a: do not compress man pages
authorAkinori Hattori <hattya@gentoo.org>
Sat, 19 Jan 2019 15:27:16 +0000 (00:27 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 19 Jan 2019 15:27:16 +0000 (00:27 +0900)
Closes: https://bugs.gentoo.org/675402
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

app-text/po4a/files/po4a-man.patch [new file with mode: 0644]
app-text/po4a/po4a-0.47-r1.ebuild
app-text/po4a/po4a-0.54.ebuild
app-text/po4a/po4a-0.55.ebuild

diff --git a/app-text/po4a/files/po4a-man.patch b/app-text/po4a/files/po4a-man.patch
new file mode 100644 (file)
index 0000000..6dd94ae
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/Po4aBuilder.pm
++++ b/Po4aBuilder.pm
+@@ -233,7 +233,6 @@
+         }
+         $parser->parse_from_file ($file, $out);
+-        system("gzip -9 -f $out") and die;
+         unlink "$file" || die;
+     }
+@@ -245,7 +244,6 @@
+         if ($file =~ m,(.*/man(.))/([^/]*)\.xml$,) {
+             my ($outdir, $section, $outfile) = ($1, $2, $3);
+             system("xsltproc -o $outdir/$outfile.$section --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $file") and die;
+-            system ("gzip -9 -f $outdir/$outfile.$section") and die;
+         }
+         unlink "$file" || die;
+     }
index 94311ba3d578aa19d541d223d7291d60073dfb35..dcf757c2f2b7c5696d155c264e8ba6e460a018a7 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -37,8 +37,10 @@ DIST_TEST="do"
 
 PATCHES=(
        # Fix bad escaping of '.' in @INC modification
-       "${FILESDIR}/${PN}-0.45-614122-no-dot-inc.patch"
+       "${FILESDIR}"/${PN}-0.45-614122-no-dot-inc.patch
+       "${FILESDIR}"/${PN}-man.patch
 )
+
 src_prepare() {
        # Check against locale files in ${S}/pod/bin for mismatches
        # with languages listed in PLOCALES
index 52fdda5fc38be27b4ee4c8c84b467db1324856b2..45fe4908e046f05749818854bd58c10592fa698a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
                virtual/tex-base
        )"
 
+PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+
 PERL_RM_FILES=(
        t/09-html.t
 )
index 1ff6a7d4df6a6a864afa70564fc5f0cc275df29d..45fe4908e046f05749818854bd58c10592fa698a 100644 (file)
@@ -8,7 +8,7 @@ inherit perl-module l10n
 
 DESCRIPTION="Tools to ease the translation of documentation"
 HOMEPAGE="https://po4a.org/"
-SRC_URI="https://github.com/mquinson/po4a/releases/download/v${PV}/${P}.tar.gz"
+SRC_URI="https://github.com/mquinson/${PN}/releases/download/v${PV}/${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
                virtual/tex-base
        )"
 
+PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+
 PERL_RM_FILES=(
        t/09-html.t
 )
@@ -48,8 +50,3 @@ src_prepare() {
 
        perl-module_src_prepare
 }
-
-src_install() {
-       perl-module_src_install
-       find "${ED%/}/usr/share/man" -name '*.gz' -exec gzip -d '{}' +
-}