app-emulation/spice: Move some dependencies into BDEPEND for EAPI 7
authorJames Le Cuirot <chewi@gentoo.org>
Wed, 18 Sep 2019 21:38:45 +0000 (22:38 +0100)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 22 Sep 2019 02:29:02 +0000 (21:29 -0500)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/spice/spice-0.14.2.ebuild
app-emulation/spice/spice-9999.ebuild

index 464cb7d9c62e567a115d5bfaa05578a092223a88..58de3c678521eaf4bb8cc5622195eea3112c5237 100644 (file)
@@ -33,22 +33,22 @@ RDEPEND="
                media-libs/gst-plugins-base:1.0
        )"
 DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
        >=app-emulation/spice-protocol-0.14.0
+       smartcard? ( app-emulation/qemu[smartcard] )"
+BDEPEND="${PYTHON_DEPS}
        virtual/pkgconfig
        $(python_gen_any_dep '
                >=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]
                dev-python/six[${PYTHON_USEDEP}]
-       ')
-       smartcard? ( app-emulation/qemu[smartcard] )"
+       ')"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-0.14.0-openssl1.1_fix.patch
 )
 
 python_check_deps() {
-       has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
-       has_version "dev-python/six[${PYTHON_USEDEP}]"
+       has_version -b ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
+       has_version -b "dev-python/six[${PYTHON_USEDEP}]"
 }
 
 pkg_setup() {
index 48cf0c3fa264583c91021e4554bb797c4cc1c9d0..62dc9f95d49e21d9f64cb26a87a065d50a0b05de 100644 (file)
@@ -34,18 +34,18 @@ RDEPEND="
                media-libs/gst-plugins-base:1.0
        )"
 DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
        ~app-emulation/spice-protocol-9999
+       smartcard? ( app-emulation/qemu[smartcard] )"
+BDEPEND="${PYTHON_DEPS}
        virtual/pkgconfig
        $(python_gen_any_dep '
                >=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]
                dev-python/six[${PYTHON_USEDEP}]
-       ')
-       smartcard? ( app-emulation/qemu[smartcard] )"
+       ')"
 
 python_check_deps() {
-       has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
-       has_version "dev-python/six[${PYTHON_USEDEP}]"
+       has_version -b ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
+       has_version -b "dev-python/six[${PYTHON_USEDEP}]"
 }
 
 pkg_setup() {