dev-haskell/shelly: tweak for ghc-8.0.2
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:33:46 +0000 (21:33 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:57:08 +0000 (21:57 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/shelly/files/shelly-1.6.8.1-ghc-8.0.2_rc1.patch [new file with mode: 0644]
dev-haskell/shelly/shelly-1.6.8.1.ebuild

diff --git a/dev-haskell/shelly/files/shelly-1.6.8.1-ghc-8.0.2_rc1.patch b/dev-haskell/shelly/files/shelly-1.6.8.1-ghc-8.0.2_rc1.patch
new file mode 100644 (file)
index 0000000..078f979
--- /dev/null
@@ -0,0 +1,9 @@
+diff --git a/src/Shelly/Pipe.hs b/src/Shelly/Pipe.hs
+index 7fe7d98..cc5668d 100644
+--- a/src/Shelly/Pipe.hs
++++ b/src/Shelly/Pipe.hs
+@@ -121,3 +121,3 @@ import Data.Text as T hiding (concat, all, find, cons)
+-default (T.Text)
++-- default (T.Text)
index bffac6ca6ed7a81aeef0931936a2678bb8568524..ddb90b352c080e9ed4557e5ae16e96ef254e8abf 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -40,6 +40,15 @@ DEPEND="${RDEPEND}
                >=dev-haskell/text-0.11 )
 "
 
+PATCHES=("${FILESDIR}"/${P}-ghc-8.0.2_rc1.patch)
+
+src_prepare() {
+       default
+
+       cabal_chdeps \
+               'directory                 >= 1.1.0.0 && < 1.3.0.0' 'directory                 >= 1.1.0.0'
+}
+
 src_configure() {
        haskell-cabal_src_configure \
                $(cabal_flag examples build-examples) \