sci-libs/mpir: pass --with-yasm=/bin/false on non-x86 archs
authorMike Gilbert <floppym@gentoo.org>
Mon, 11 Nov 2019 21:48:10 +0000 (16:48 -0500)
committerMike Gilbert <floppym@gentoo.org>
Mon, 11 Nov 2019 21:48:42 +0000 (16:48 -0500)
Closes: https://bugs.gentoo.org/661430
Package-Manager: Portage-2.3.78_p18, Repoman-2.3.17_p114
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
sci-libs/mpir/mpir-3.0.0.ebuild

index 9fd8a755b58d1649c633ee870dac71aac0ecfc3b..6efc062bb0ada6da8d901c578b72e06a8694a619 100644 (file)
@@ -59,12 +59,16 @@ src_configure() {
        # beware that cpudetection aka fat binaries is x86/amd64 only.
        # Place mpir in profiles/arch/$arch/package.use.mask
        # when making it available on $arch.
-       local myeconfargs+=(
+       local myeconfargs=(
                $(use_enable cxx)
                $(use_enable cpudetection fat)
                $(use_enable static-libs static)
        )
-       econf ${myeconfargs[@]}
+       # https://bugs.gentoo.org/661430
+       if !use amd64 && !use x86; then
+               myeconfargs+=( --with-yasm=/bin/false )
+       fi
+       econf "${myeconfargs[@]}"
 }
 
 src_install() {