dev-haskell/lens-family-core: new package, a depend of dev-haskell/persistent-2.6
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 08:36:18 +0000 (08:36 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 10:21:54 +0000 (10:21 +0000)
Haskell 98 Lens Families

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/lens-family-core/Manifest [new file with mode: 0644]
dev-haskell/lens-family-core/lens-family-core-1.2.1.ebuild [new file with mode: 0644]
dev-haskell/lens-family-core/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/lens-family-core/Manifest b/dev-haskell/lens-family-core/Manifest
new file mode 100644 (file)
index 0000000..539624c
--- /dev/null
@@ -0,0 +1 @@
+DIST lens-family-core-1.2.1.tar.gz 11756 SHA256 95e3b9876a6cdcc6865bfad22e04af41430c7a9a6bc96e9a25a2a35a841d19a4 SHA512 1bdb98da1b52d44c1c6d28b92eea4452253925b813b96b04c7d7b25d0e62e91be987106d41ed8bb298173577ad3b50a24508db5bf75d501828e33218b80497e1 WHIRLPOOL a4853eee6c4e1af11a504b2b7d182ac34a71f8e2b4bbe81bc7f3cbe072333f2fdd954ea32825742a6deae9cc6934a4ef6568bbe706a4de5b7d56c713b369cebb
diff --git a/dev-haskell/lens-family-core/lens-family-core-1.2.1.ebuild b/dev-haskell/lens-family-core/lens-family-core-1.2.1.ebuild
new file mode 100644 (file)
index 0000000..cbf26cd
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell 98 Lens Families"
+HOMEPAGE="http://hackage.haskell.org/package/lens-family-core"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-0.2.0:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/lens-family-core/metadata.xml b/dev-haskell/lens-family-core/metadata.xml
new file mode 100644 (file)
index 0000000..291ddcb
--- /dev/null
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               This package provides first class( ) functional references.
+               In addition to the usual operations of getting, setting and composition, plus integration with the state monad, lens families provide some unique features:
+               
+               * Polymorphic updating
+               
+               * Traversals
+               
+               * Cast projection functions to read-only lenses
+               
+               * Cast \"toList\" functions to read-only traversals
+               
+               * Cast semantic editor combinators to modify-only traversals.
+               
+               ( ) For optimal first-class support use the @lens-family@ package with rank 2 / rank N polymorphism.
+               "Lens.Family.Clone" allows for first-class support of lenses and traversals for those who require Haskell 98.
+       </longdescription>
+</pkgmetadata>