dev-python/apsw: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 11:04:22 +0000 (12:04 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 11:15:38 +0000 (12:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/apsw/Manifest
dev-python/apsw/apsw-3.23.1_p1.ebuild [deleted file]

index 67013b62c558f7678b783f68d48fd1d065a73d7b..fb007b559fff8462f935d0442ce6338468c4e5f3 100644 (file)
@@ -1,2 +1 @@
-DIST apsw-3.23.1_p1.zip 682088 BLAKE2B 0b1c492c68522f9d3d1c693370b3b1562de0e4521f3a3de0988c40ddcf717f79201555228c16b9b9870db47582bf2b774f7e9ce0ddea4e19c3d132bbf2322551 SHA512 8f3bc9e619ed8671a0804e6d3c9ecf34d452a4e6fe540fb23bfb6ae67578971013300ad6cdffe3be2fc1197c4fd3af096802aef5994cbe53253467133363ac62
 DIST apsw-3.25.2_p1.zip 682975 BLAKE2B f9f471378cddd7da1c06158b7a041d9377da4d4123846318c0cfc24167734bc1813f667e64c4c6bf643c6a618c9cabf58301dfbaad0998082d764212ea369fff SHA512 073b2fe9170fb00ac6f2ba52eb638d64d79875ba74b09f0307fa2c075e714bb91465fd2edd46341dac5cedc0bee0a1099888b6c1cee706fc04fa6b9ad99c47d7
diff --git a/dev-python/apsw/apsw-3.23.1_p1.ebuild b/dev-python/apsw/apsw-3.23.1_p1.ebuild
deleted file mode 100644 (file)
index 8008017..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 flag-o-matic
-
-MY_PV=${PV/_p/-r}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="https://github.com/rogerbinns/apsw/"
-SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc64 x86"
-IUSE="doc"
-
-RDEPEND=">=dev-db/sqlite-${PV%_p*}"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )
-
-python_compile() {
-       python_is_python3 || append-cflags -fno-strict-aliasing
-       distutils-r1_python_compile --enable=load_extension
-}
-
-python_test() {
-       "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
-       "${PYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/. )
-       distutils-r1_python_install_all
-}