dev-python/cffi: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Wed, 11 Mar 2020 19:39:58 +0000 (20:39 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 11 Mar 2020 19:43:59 +0000 (20:43 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cffi/Manifest
dev-python/cffi/cffi-1.11.4.ebuild [deleted file]
dev-python/cffi/cffi-1.11.5.ebuild [deleted file]

index 2229e2b89630521b159854ab993f394c079b8340..92cabc666cfb8d385c76dc56e17dc44a476c3bff 100644 (file)
@@ -1,4 +1,2 @@
-DIST cffi-1.11.4.tar.gz 436857 BLAKE2B 46b5d1adf4aca2a75ea02ba01ae934821d0e864accd9c355745a681d11a08ed34c33c473204c78ecb2113b2d59fbc762ca0607ff92f6cd2dc411907844bbdaf3 SHA512 184572ab8c1f7a72f00084c23894efe1691aa20f9e822a3f7184ebbed16e757586ac47e7f1d12dd7b14b4322bf5b88e35465dc3bc8b0caf0dc8e2b626a52615e
-DIST cffi-1.11.5.tar.gz 438498 BLAKE2B 2e22cf3c2d50d76f8f25b7ac31a77fac8a49e2b2f4952e3b1a1da79c0ad2ca5c6e450000cadd1efa06df53d14f711e0acd73a075bea45ebd61e667fb650a10ab SHA512 6770d5293cfd7405e733d60c96655641b5bcc5878fc66a737f4a8308f465d459ee0e3fcaa47893d8f57fb195e5534dd7e4728c868f33d7e657688f45e1fb1880
 DIST cffi-1.13.2.tar.gz 460243 BLAKE2B 74603f2b1bde068a955e94912488fd7d8914267ec2d0cbd8574f62376fc24ef16d85d59e9fee7f6015e6d242726ea25235788faddedc68deb56ae71e627d6322 SHA512 2c57d9c06c39e95498a54408dc39940427190f3c03e1b8f1a3584140db08a5775dd12e6e67b03093429c130af579d01519b0fc868b99ba7a530068ed22d38522
 DIST cffi-1.14.0.tar.gz 463065 BLAKE2B 4d1e8a92241db801848ef8bd05ea15a31c7f61ea426ce4da184aff00df786348d2c76de9dc48898c814478aed9750b665868df24ad39435062cd7e1c84163e52 SHA512 4c5451eeede1d48a8f4b40e25b845ad1863b8bf3bd39624e6c693c2800d89a13efedc4c43b37e317a035613bffc2e3fd5f7e583c46cb283cb5cb930356f86253
diff --git a/dev-python/cffi/cffi-1.11.4.ebuild b/dev-python/cffi/cffi-1.11.4.ebuild
deleted file mode 100644 (file)
index cde54ff..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# DO NOT ADD pypy to PYTHON_COMPAT
-# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Foreign Function Interface for Python calling C code"
-HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       virtual/libffi:=
-       dev-python/pycparser[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_test() {
-       einfo "$PYTHONPATH"
-       $PYTHON -c "import _cffi_backend as backend" || die
-       PYTHONPATH="${PYTHONPATH}" \
-       py.test -x -v \
-               --ignore testing/test_zintegration.py \
-               --ignore testing/embedding \
-               c/ testing/ \
-               || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/cffi/cffi-1.11.5.ebuild b/dev-python/cffi/cffi-1.11.5.ebuild
deleted file mode 100644 (file)
index 18166d4..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# DO NOT ADD pypy to PYTHON_COMPAT
-# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Foreign Function Interface for Python calling C code"
-HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       virtual/libffi:=
-       dev-python/pycparser[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
-DISTUTILS_IN_SOURCE_BUILD=1
-
-src_configure() {
-       tc-export PKG_CONFIG
-}
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_test() {
-       einfo "$PYTHONPATH"
-       $PYTHON -c "import _cffi_backend as backend" || die
-       PYTHONPATH="${PYTHONPATH}" \
-       py.test -x -v \
-               --ignore testing/test_zintegration.py \
-               --ignore testing/embedding \
-               c/ testing/ \
-               || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/build/html/. )
-       distutils-r1_python_install_all
-}