app-text/libspectre: Drop 0.2.7
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 1 Jan 2020 10:40:03 +0000 (11:40 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 1 Jan 2020 11:01:10 +0000 (12:01 +0100)
hppa had no revdeps.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-text/libspectre/Manifest
app-text/libspectre/files/libspectre-0.2.7-gs918.patch [deleted file]
app-text/libspectre/libspectre-0.2.7.ebuild [deleted file]

index 23d84a9fb97446bbf3350495e46114b8c8070352..54fa010bd956cb2b7c837f052ad3b50db6f10beb 100644 (file)
@@ -1,2 +1 @@
-DIST libspectre-0.2.7.tar.gz 387947 BLAKE2B 1d8c5ce045e90cb10a159615d3b011dafd24fa07c8bbd79349663880d077b53944495cba7f5a77e8e32735123762d0f6fcd2feb382258b8d35107284f72243b8 SHA512 2e60905f7eeed9ac6ec3b5f8b47a7dad85178c8c35a63ba097ef6088dd334f7fde5797ecb05cf67532b759d07a65006427914d2cd6b09107ecc90620c9541794
 DIST libspectre-0.2.8.tar.gz 421791 BLAKE2B bbefa06cf80ecb91f0f780493e1829eadc34061b6f2b3004f9ae01e06fc4609edd440df290be9ff1c9f43e580b53791aae033feb4115743a0f03f703bc18e0c7 SHA512 ebbe7f6adcbc7f7d6af61f24e23b114116c878755dbe90f1163546c1284a005b4d539be01986c1f940611e84141ca19768b8effc2abf1013606da7c93547da86
diff --git a/app-text/libspectre/files/libspectre-0.2.7-gs918.patch b/app-text/libspectre/files/libspectre-0.2.7-gs918.patch
deleted file mode 100644 (file)
index e9a4eda..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-Fixed error namespace for >=ghostscript-gpl-9.18
-
-https://bugs.gentoo.org/563540
-
---- libspectre-0.2.7/libspectre/spectre-gs.c
-+++ libspectre-0.2.7/libspectre/spectre-gs.c
-@@ -43,12 +43,12 @@
-       
-       if (code <= -100) {
-               switch (code) {
--                      case e_Fatal:
-+                      case gs_error_Fatal:
-                               fprintf (stderr, "fatal internal error %d", code);
-                               return TRUE;
-                               break;
--                      case e_ExecStackUnderflow:
-+                      case gs_error_ExecStackUnderflow:
-                               fprintf (stderr, "stack overflow %d", code);
-                               return TRUE;
-                               break;
-@@ -109,9 +109,9 @@
-               set = _spectre_strdup_printf ("%d %d translate\n", -x, -y);
-               error = gsapi_run_string_continue (ghostscript_instance, set, strlen (set),
-                                                  0, &exit_code);
--              error = error == e_NeedInput ? 0 : error;
-+              error = error == gs_error_NeedInput ? 0 : error;
-               free (set);
--              if (error != e_NeedInput && critic_error_code (error)) {
-+              if (error != gs_error_NeedInput && critic_error_code (error)) {
-                       fclose (fd);
-                       return FALSE;
-               }
-@@ -126,7 +126,7 @@
-               read = fread (buf, sizeof (char), to_read, fd);
-               error = gsapi_run_string_continue (ghostscript_instance,
-                                                  buf, read, 0, &exit_code);
--              error = error == e_NeedInput ? 0 : error;
-+              error = error == gs_error_NeedInput ? 0 : error;
-               left -= read;
-       }
-       
diff --git a/app-text/libspectre/libspectre-0.2.7.ebuild b/app-text/libspectre/libspectre-0.2.7.ebuild
deleted file mode 100644 (file)
index d250899..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit autotools eutils
-
-DESCRIPTION="A library for rendering Postscript documents"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/libspectre"
-SRC_URI="https://libspectre.freedesktop.org/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
-IUSE="debug doc static-libs"
-
-RDEPEND=">=app-text/ghostscript-gpl-8.62"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       doc? ( app-doc/doxygen )"
-
-# does not actually test anything, see bug 362557
-RESTRICT="test"
-
-DOCS="NEWS README TODO"
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-0.2.0-interix.patch
-       has_version \>=app-text/ghostscript-gpl-9.18 \
-               && epatch "${FILESDIR}"/${PN}-0.2.7-gs918.patch
-       eautoreconf # need new libtool for interix
-}
-
-src_configure() {
-       econf \
-               $(use_enable debug asserts) \
-               $(use_enable debug checks) \
-               $(use_enable static-libs static) \
-               --disable-test
-}
-
-src_compile() {
-       emake
-       if use doc; then
-               doxygen || die
-       fi
-}
-
-src_install() {
-       default
-       use doc && dohtml -r doc/html/*
-       find "${D}" -name '*.la' -exec rm -f {} +
-}