www-client/phantomjs: Add GCC compilation patch
authorDion Moult <moult@gentoo.org>
Sat, 26 Sep 2015 23:28:19 +0000 (09:28 +1000)
committerDion Moult <moult@gentoo.org>
Sat, 26 Sep 2015 23:28:19 +0000 (09:28 +1000)
Package-Manager: portage-2.2.15

www-client/phantomjs/files/phantomjs-gcc5-compile-fix.patch [new file with mode: 0644]
www-client/phantomjs/phantomjs-2.0.0.ebuild

diff --git a/www-client/phantomjs/files/phantomjs-gcc5-compile-fix.patch b/www-client/phantomjs/files/phantomjs-gcc5-compile-fix.patch
new file mode 100644 (file)
index 0000000..7191050
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/src/qt/qtwebkit/Source/JavaScriptCore/runtime/JSObject.cpp       2015-01-24 08:19:52.000000000 +0600
++++ b/src/qt/qtwebkit/Source/JavaScriptCore/runtime/JSObject.cpp       2015-09-24 18:18:45.598322592 +0600
+@@ -1909,6 +1909,11 @@
+     }
+ }
++// Used in JSArray.cpp so we must instantiate explicit
++template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<Int32Shape>(ExecState* exec, unsigned i, JSValue value);
++template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<DoubleShape>(ExecState* exec, unsigned i, JSValue value);
++template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<ContiguousShape>(ExecState* exec, unsigned i, JSValue value);
++
+ void JSObject::putByIndexBeyondVectorLengthWithArrayStorage(ExecState* exec, unsigned i, JSValue value, bool shouldThrow, ArrayStorage* storage)
+ {
+     VM& vm = exec->vm();
index 6b6a81d69de6b15ffd6bba9ed366fc3ef9e0b43e..e52d78f5893c71d5896ec8f5f85f201d54f7d080 100644 (file)
@@ -33,6 +33,7 @@ DEPEND="${RDEPEND}
 
 src_prepare() {
        epatch "${FILESDIR}/phantomjs-python3-udis86-itab.patch"
+       epatch "${FILESDIR}/phantomjs-gcc5-compile-fix.patch"
 
        # Respect CC, CXX, {C,CXX,LD}FLAGS in .qmake.cache
        sed -i \