net-mail/cmd5checkpw: drop old EAPI
authorAaron Bauman <bman@gentoo.org>
Sun, 10 Nov 2019 16:37:14 +0000 (11:37 -0500)
committerAaron Bauman <bman@gentoo.org>
Sun, 10 Nov 2019 16:37:44 +0000 (11:37 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
net-mail/cmd5checkpw/Manifest
net-mail/cmd5checkpw/cmd5checkpw-0.30-r1.ebuild [deleted file]

index f8a8d35cf6fdba84bc5561874397e27a540fbe23..0853450b258d7e8339a2aa6b434cacc577d5e0d1 100644 (file)
@@ -1,2 +1 @@
-DIST cmd5checkpw-030_tgz.bin 25812 BLAKE2B d1ef48edd2ff0d88823656915a04a8f0893840a49022ed977c6d178cf70d179c44504512ad44d94ae33d48e523ae8cb98ff7b87357b6c8deee761ae9df163bc5 SHA512 c54792769097ac7e8a11c6a140a9eefdb090bad4a0336be9543549a232e4faa72f08baea7e746b9743e01ce40c0f7402f4584c53b5eedb3f2d1e457d1c8a45d5
 DIST cmd5checkpw-0.30.tar.gz 25812 BLAKE2B d1ef48edd2ff0d88823656915a04a8f0893840a49022ed977c6d178cf70d179c44504512ad44d94ae33d48e523ae8cb98ff7b87357b6c8deee761ae9df163bc5 SHA512 c54792769097ac7e8a11c6a140a9eefdb090bad4a0336be9543549a232e4faa72f08baea7e746b9743e01ce40c0f7402f4584c53b5eedb3f2d1e457d1c8a45d5
diff --git a/net-mail/cmd5checkpw/cmd5checkpw-0.30-r1.ebuild b/net-mail/cmd5checkpw/cmd5checkpw-0.30-r1.ebuild
deleted file mode 100644 (file)
index a2ac986..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils fixheadtails user
-
-MY_VER="030"
-
-DESCRIPTION="A checkpassword compatible authentication program that used CRAM-MD5 authentication mode"
-SRC_URI="https://www.fehcom.de/qmail/auth/${PN}-${MY_VER}_tgz.bin"
-HOMEPAGE="https://www.fehcom.de/qmail/smtpauth.html"
-
-LICENSE="public-domain RSA"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-pkg_setup() {
-       enewuser cmd5checkpw 212 -1 /dev/null bin
-       ewarn
-       ewarn "this version is in NO WAY COMPATIBLE with cmd5checkpw-0.2x"
-       ewarn "it actually receives the authentication credentials"
-       ewarn "in a different order then the old implementation"
-       ewarn "see bug #100693 for details"
-       ewarn "this version IS needed by >=qmail-1.03-r16"
-       ewarn
-}
-
-src_unpack() {
-       # The old code moved the file in DISTDIR, which is forbidden.
-       # It's read-only.
-       cd "${WORKDIR}"
-       rm -f ${PN}-${MY_VER}.tar.gz
-       ln -s "${DISTDIR}"/${PN}-${MY_VER}_tgz.bin ${PN}-${MY_VER}.tar.gz
-       unpack ./${PN}-${MY_VER}.tar.gz
-       cd "${S}"
-
-       epatch "${FILESDIR}"/euid_${MY_VER}.diff
-       epatch "${FILESDIR}"/reloc.diff
-
-       sed -e 's:-c -g -Wall -O3:$(OPTCFLAGS):' -i Makefile
-
-       ht_fix_file Makefile
-}
-
-src_compile() {
-       emake OPTCFLAGS="${CFLAGS}" || die
-}
-
-src_install() {
-       insinto /etc
-       doins "${FILESDIR}"/poppasswd
-
-       exeinto /bin
-       doexe cmd5checkpw
-       doman cmd5checkpw.8
-
-       fowners cmd5checkpw /etc/poppasswd /bin/cmd5checkpw
-       fperms 400 /etc/poppasswd
-       fperms u+s /bin/cmd5checkpw
-}
-
-pkg_postinst() {
-       chmod 400 "${ROOT}"/etc/poppasswd
-       chown cmd5checkpw "${ROOT}"/etc/poppasswd
-}