dev-python/python-language-server: fix dep versions
authorWGH <wgh@torlan.ru>
Mon, 24 Feb 2020 18:45:54 +0000 (21:45 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 25 Feb 2020 14:50:34 +0000 (16:50 +0200)
Copy dependency version bounds from the upstream setup.py:
https://github.com/palantir/python-language-server/blob/0.31.8/setup.py#L38

This fixes the problem when e.g. older jedi satisfies the ebuild
dependency, but the package itself checks dependency specified it
in its setup.py at runtime, refusing to work on mismatch (see #710684).
If pyls silently accepted wrong package version it could've been worse,
though.

Closes: https://bugs.gentoo.org/710684
Signed-off-by: Maxim Plotnikov <wgh@torlan.ru>
Closes: https://github.com/gentoo/gentoo/pull/14761
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/python-language-server/python-language-server-0.31.8.ebuild

index 0ebc9ebc1a90499c3630cefb3aceca1e0fc96e8e..53b3086f0cdd5d054802b9115f48e58a79e2f3e2 100644 (file)
@@ -19,10 +19,12 @@ KEYWORDS="~amd64 ~x86"
 
 BDEPEND="dev-python/versioneer[${PYTHON_USEDEP}]"
 
-RDEPEND="dev-python/jedi[${PYTHON_USEDEP}]
+RDEPEND="
+       >=dev-python/jedi-0.14.1[${PYTHON_USEDEP}]
+       <dev-python/jedi-0.16.0[${PYTHON_USEDEP}]
        dev-python/pluggy[${PYTHON_USEDEP}]
-       dev-python/python-jsonrpc-server[${PYTHON_USEDEP}]
-       dev-python/ujson[${PYTHON_USEDEP}]"
+       >=dev-python/python-jsonrpc-server-0.3.2[${PYTHON_USEDEP}]
+       <=dev-python/ujson-1.35[${PYTHON_USEDEP}]"
 
 DEPEND="test? (
        dev-python/autopep8[${PYTHON_USEDEP}]