Reflect move of libvirt repositories
authorMichal Privoznik <mprivozn@redhat.com>
Thu, 23 Apr 2020 09:46:07 +0000 (11:46 +0200)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 26 Apr 2020 20:18:04 +0000 (21:18 +0100)
Libvirt and related projects moved from self hosting to
gitlab.com hosting. The old repos were made a read only mirror of
their gitlab images. Reflect this change in the live ebuilds.

https://www.redhat.com/archives/libvir-list/2020-April/msg00329.html

Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
Closes: https://github.com/gentoo/gentoo/pull/15478
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
app-emulation/libvirt/libvirt-9999.ebuild
dev-php/libvirt-php/libvirt-php-9999.ebuild
dev-python/libvirt-python/libvirt-python-9999.ebuild

index a761557096f1724564993ed5d08a6bd91cc59792..7e2d3a8c23b9f29cbb14802374f5292b8d219d7a 100644 (file)
@@ -9,7 +9,7 @@ inherit autotools out-of-source bash-completion-r1 eutils linux-info python-any-
 
 if [[ ${PV} = *9999* ]]; then
        inherit git-r3
-       EGIT_REPO_URI="https://libvirt.org/git/libvirt.git"
+       EGIT_REPO_URI="https://gitlab.com/libvirt/libvirt.git"
        SRC_URI=""
        KEYWORDS=""
        SLOT="0"
index 066640b361aadf91934d3e8660dd36de1189740a..2963ecd32d733656201c0481788f44a592acbe2a 100644 (file)
@@ -12,7 +12,7 @@ inherit php-ext-source-r3 git-r3 autotools
 
 DESCRIPTION="PHP bindings for libvirt"
 HOMEPAGE="http://libvirt.org/php/"
-EGIT_REPO_URI="git://libvirt.org/libvirt-php.git"
+EGIT_REPO_URI="https://gitlab.com/libvirt/libvirt-php.git"
 
 LICENSE="LGPL-2.1"
 SLOT="0"
index 607c6f77b7f4cc43d567ca98204ce3528a8e2017..14a5fba8787a341ef4715fc4472698fe424f9daf 100644 (file)
@@ -11,7 +11,7 @@ inherit distutils-r1
 
 if [[ ${PV} = *9999* ]]; then
        inherit git-r3
-       EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
+       EGIT_REPO_URI="https://gitlab.com/libvirt/libvirt-python.git"
        SRC_URI=""
        KEYWORDS=""
        RDEPEND="app-emulation/libvirt:=[-python(-)]"