dev-python/django-otp: Bump to 0.9.0, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 11:07:14 +0000 (13:07 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 11:24:21 +0000 (13:24 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/django-otp/Manifest
dev-python/django-otp/django-otp-0.9.0.ebuild [new file with mode: 0644]

index f45cdc8646a21197df453a52651d0d024ae84909..7ee064d8e4cf50251a1a036aae931bdc8b9c0829 100644 (file)
@@ -1 +1,2 @@
 DIST django-otp-0.4.3.tar.gz 42480 BLAKE2B 09398e4e06425fefdda45a3a200576efda9409a42fb8f1c640a996e066e1ad2cf47e6ee0879e4a61cdc64808fe8f030aba19dfd99fa4da7d3e86597bda881d09 SHA512 3f3ec761dc12ed40e8c757dfbe1fd951c7c6aed3abc311c823acdeca08d5864b54c8442a49807228be17b30c20093b1ba7fb8b2c0f86f00dc1cc215ccd7c28de
+DIST django-otp-0.9.0.gh.tar.gz 60204 BLAKE2B c71b27e007580410fea3cf8110631801c8c08f7e325c3586cb5a41a9618b371b5d65e3b030a5b483cb6cda684fe837cd40aa1c5d04f54dc82cda750b8ba8aeb9 SHA512 dd3c99e928ebf1ba5b6f6b2f34fcf8a1f86ad64ece17a9bd97c56be239f165808f6d1025e2826a12a8eadc150fe49920a0b7ef398d83542cd97a4a6f391505fe
diff --git a/dev-python/django-otp/django-otp-0.9.0.ebuild b/dev-python/django-otp/django-otp-0.9.0.ebuild
new file mode 100644 (file)
index 0000000..4bbf7d9
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+       https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+               -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/django-1.11[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+       local -x PYTHONPATH=test:${PYTHONPATH}
+       local -x DJANGO_SETTINGS_MODULE=test_project.settings
+       django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}