dev-python/reno: 2.5.0 bup
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 27 Aug 2017 00:34:31 +0000 (19:34 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 27 Aug 2017 04:23:59 +0000 (23:23 -0500)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-python/reno/Manifest
dev-python/reno/reno-2.5.0.ebuild [new file with mode: 0644]

index 9feb9110d6a750bbb64beed659ef2cd60ab534f6..6d21b942985b7ccd1f1dcad5ea62750b4aadecac 100644 (file)
@@ -1 +1,2 @@
 DIST reno-2.2.1.tar.gz 56013 SHA256 2feebbeb0fa0cfd4cd19d7fba5bdd334a10a82515b1d8c3c5fc732c076c84ec7 SHA512 278a7a43168f9467342f25c3eb8692e119cac285940b5d3f5a13f8f45acaffde962d2eeac720f2e5d824d085446fe5d660ef7082f95dd3c0360d594de5a65fb1 WHIRLPOOL 30203bbb1f1f8749e43b4c5a3cfe2dd3bfbd5ecf63b9fbcd6a47e8f148d58cd02c895311557919f4e2e27fafda326162edc9df77f71fb3c258b5dc1a6e7295ce
+DIST reno-2.5.0.tar.gz 62819 SHA256 328912f3c4cfb8645fba13d85fca8e490a028e36a627116485eac5e1fd680b66 SHA512 ee7c44235dd1c3c253b426abbafd490658d642d56ebac5688dd1e3fca45451f26855f421b252c64f9e143bd67c8b08a9e4c6b79edc9c7341b26150a576458570 WHIRLPOOL a6ac41c0228750059188deb399994219bec5589dc93f837e283f6c445a978d8438481816f1c2c1935e9a618c82817b00912d2ea924cff18f5a59678ab93d2451
diff --git a/dev-python/reno/reno-2.5.0.ebuild b/dev-python/reno/reno-2.5.0.ebuild
new file mode 100644 (file)
index 0000000..d13673c
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="https://pypi.python.org/pypi/reno"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.4[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"