net-dns/bind-tools: Drop old
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 24 Nov 2019 14:25:47 +0000 (17:25 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 24 Nov 2019 14:25:47 +0000 (17:25 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
net-dns/bind-tools/Manifest
net-dns/bind-tools/bind-tools-9.15.5.ebuild [deleted file]

index 00f0245aa9affb4e4ddef7112de59ea8e3b9707d..f399cfabfd98c869aca1bc4ea01890279d19df09 100644 (file)
@@ -1,3 +1,2 @@
 DIST bind-9.14.8.tar.gz 6403140 BLAKE2B 45cb06ce8564880d501c63d25c7af8567184e4e4293e01886620cf655449c972ab55c77c7aded07838c61557bc56d9edac26097715c1121fcfb6b606d7a29365 SHA512 eb52760982ebd246e6e1945684771193fc7364324a6d6a95a0cae33afa0a4fa24ffe8313b5f9094420c7c2ec932b1b1a9fb19f6e673ff3c5583ab5e3ff04eb6a
-DIST bind-9.15.5.tar.gz 6303092 BLAKE2B 82bc078a6540d8847ecf39c8b29a58175db2ed7017c8cfd9a40a88292ece0935d532ea02fea09143c48e2949c912eab90d41d199cf8acdb3d69b13bf6aa669c7 SHA512 7632402dfe30c83c732ea6a4079a36e8529e4dd0541d794167d43103e8cd5257709af74d5823c65f4fe4c8fe5ca80c514e66fafbb2302ccd94973b86c67a1978
 DIST bind-9.15.6.tar.gz 6432248 BLAKE2B c6dbaeeafdad3e2c7dd30ed1e5121c961829af8d82b9b93dd4eca34d96dfc2854e302068987dcd30ab88c768f6328c81bf81b348a698ceb11001d4d700ef374f SHA512 3bf7ebde706a6771606fda675c60daccbb22c2dc9551a8f361fe102b59e342ded99568b27bca7d7fa32d3f2be3811f38ec014f4ad0c281b590b7b69967395cb7
diff --git a/net-dns/bind-tools/bind-tools-9.15.5.ebuild b/net-dns/bind-tools/bind-tools-9.15.5.ebuild
deleted file mode 100644 (file)
index 5a710f6..0000000
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic toolchain-funcs
-
-MY_PN=${PN//-tools}
-MY_PV=${PV/_p/-P}
-MY_PV=${MY_PV/_rc/rc}
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
-HOMEPAGE="https://www.isc.org/software/bind"
-SRC_URI="https://downloads.isc.org/isc/bind9/${PV}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 GPL-2 HPND ISC MPL-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="+caps doc gssapi idn ipv6 libedit libressl readline xml"
-# no PKCS11 currently as it requires OpenSSL to be patched, also see bug 409687
-
-COMMON_DEPEND="
-       caps? ( sys-libs/libcap )
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       xml? ( dev-libs/libxml2 )
-       idn? ( net-dns/libidn2:= )
-       gssapi? ( virtual/krb5 )
-       libedit? ( dev-libs/libedit )
-       !libedit? (
-               readline? ( sys-libs/readline:0= )
-       )"
-
-DEPEND="${COMMON_DEPEND}"
-
-RDEPEND="${COMMON_DEPEND}
-       !<net-dns/bind-9.10.2"
-
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-# bug 479092, requires networking
-RESTRICT="test"
-
-src_prepare() {
-       default
-
-       export LDFLAGS="${LDFLAGS} -L${EPREFIX}/usr/$(get_libdir)"
-
-       # Disable tests for now, bug 406399
-       sed -i '/^SUBDIRS/s:tests::' bin/Makefile.in lib/Makefile.in || die
-
-       # bug #220361
-       rm aclocal.m4 || die
-       rm -rf libtool.m4/ || die
-
-       eautoreconf
-}
-
-src_configure() {
-       local myeconfargs=(
-               --localstatedir="${EPREFIX}"/var
-               --without-python
-               --without-libjson
-               --without-zlib
-               --without-lmdb
-               --with-openssl="${EPREFIX}"/usr
-               $(use_with idn libidn2)
-               $(use_with xml libxml2)
-               $(use_with gssapi)
-               $(use_with readline)
-               $(use_enable caps linux-caps)
-       )
-
-       # bug 607400
-       if use libedit ; then
-               myeconfargs+=( --with-readline=-ledit )
-       elif use readline ; then
-               myeconfargs+=( --with-readline=-lreadline )
-       else
-               myeconfargs+=( --without-readline )
-       fi
-
-       # bug 344029
-       append-cflags "-DDIG_SIGCHASE"
-
-       # to expose CMSG_* macros from sys/sockets.h
-       [[ ${CHOST} == *-solaris* ]] && append-cflags "-D_XOPEN_SOURCE=600"
-
-       # localstatedir for nsupdate -l, bug 395785
-       tc-export BUILD_CC
-       econf "${myeconfargs[@]}"
-
-       # bug #151839
-       echo '#undef SO_BSDCOMPAT' >> config.h
-}
-
-src_compile() {
-       local AR=$(tc-getAR)
-
-       emake AR="${AR}" -C lib/
-       emake AR="${AR}" -C bin/delv/
-       emake AR="${AR}" -C bin/dig/
-       emake AR="${AR}" -C bin/nsupdate/
-       emake AR="${AR}" -C bin/dnssec/
-}
-
-src_install() {
-       dodoc README CHANGES
-
-       cd "${S}"/bin/delv || die
-       dobin delv
-       doman delv.1
-
-       cd "${S}"/bin/dig || die
-       dobin dig host nslookup
-       doman {dig,host,nslookup}.1
-
-       cd "${S}"/bin/nsupdate || die
-       dobin nsupdate
-       doman nsupdate.1
-       if use doc; then
-               docinto html
-               dodoc nsupdate.html
-       fi
-
-       cd "${S}"/bin/dnssec || die
-       for tool in dsfromkey importkey keyfromlabel keygen \
-               revoke settime signzone verify; do
-               dobin dnssec-"${tool}"
-               doman dnssec-"${tool}".8
-               if use doc; then
-                       docinto html
-                       dodoc dnssec-"${tool}".html
-               fi
-       done
-}