dev-tcltk/tkcon: EAPI 7
authorTupone Alfredo <tupone@gentoo.org>
Sat, 12 Oct 2019 13:34:40 +0000 (15:34 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Sat, 12 Oct 2019 13:34:40 +0000 (15:34 +0200)
Bugs: https://bugs.gentoo.org/697338
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-tcltk/tkcon/tkcon-2.5-r1.ebuild [new file with mode: 0644]

diff --git a/dev-tcltk/tkcon/tkcon-2.5-r1.ebuild b/dev-tcltk/tkcon/tkcon-2.5-r1.ebuild
new file mode 100644 (file)
index 0000000..cbc35d0
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib
+
+DESCRIPTION="Tk GUI console"
+HOMEPAGE="http://tkcon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="dev-lang/tk:*"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+       mv docs/changes.txt CHANGES
+}
+
+src_install() {
+       local tclver="$(echo 'puts $tcl_version' | tclsh)"
+       local instdir=/usr/$(get_libdir)/tcl${tclver}/${PN}2.5
+       dodir ${instdir}
+       cp -pP pkgIndex.tcl tkcon.tcl "${D}"${instdir} || die
+       dodir /usr/bin
+       dosym ${instdir}/tkcon.tcl /usr/bin/tkcon
+       if use doc; then
+               HTML_DOCS=( docs/* )
+       fi
+       einstalldocs
+}