sci-visualization/gnuplot: Version bump to 5.2.8.
authorUlrich Müller <ulm@gentoo.org>
Fri, 10 Apr 2020 18:46:59 +0000 (20:46 +0200)
committerUlrich Müller <ulm@gentoo.org>
Fri, 10 Apr 2020 19:04:42 +0000 (21:04 +0200)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
sci-visualization/gnuplot/Manifest
sci-visualization/gnuplot/gnuplot-5.2.8.ebuild [new file with mode: 0644]

index 542e3e28fba731ccaef81ba1f0e003877600cec4..495f5ae73e9441fc8558c87dfaa8e3a4a458a9aa 100644 (file)
@@ -1,3 +1,4 @@
 DIST gnuplot-5.0.7.tar.gz 5100186 BLAKE2B 97fcefa12148fc2b581113c5283eb09217e87858ae293931758d0bb595fd7aaca4671216956211a3d30492be35f91809a975c9c80c25861c477e9235a8b5b309 SHA512 5d7241dc1472f87af8632110a1e88f83b5ea3f41e1bc8c89a45dc4662a3071d91a25bf9ae5196a2b8bef09c8079c22f635bb947c02def3416d78880d61eea919
 DIST gnuplot-5.2.6.tar.gz 5321601 BLAKE2B 4281ba29926ee7fc046b48006fed6513dd3a9ee8bd3a6aa41c5782c5162bfc8af64ffdfec77d4996af6a634f5f3424404eab77c0efd91c65bd34412f5b8f17c7 SHA512 557c0d00c951055ca03ef0f2b262e96b8013da4fedeb64dc5325fabd94772144fd2fe7bfa9d159fa47ab76695109cb4d3f01fc5bfa996df4576aee0eebe36a90
 DIST gnuplot-5.2.7.tar.gz 5335673 BLAKE2B 6ca3055f6bb2e032562c7f21beda0adca1087598c7bacc9ab187c7ea4a3d85e08598ddb0ff0660bca081bc17899dbb92bbfbb6acde8b7b5367f12da7a2a14b62 SHA512 f6b77e16b25e5705ea9dad4f89ed5f5a3cf95d3e4215da00be3cbfbcdeee23009e9205156399448526783f25b5b7599b674670c94c01345abafeff74f6c7de93
+DIST gnuplot-5.2.8.tar.gz 5340677 BLAKE2B 169f5bef44a64b3b7a5be40e28ea22ef24ebc7526fe13ab09e16495453c3922712603d63a03c3b4332368d2ae8cbe4ef57ec53e18bbb4ad2cde13e4cc534245a SHA512 513dff15236dcb58c3c5471cdaa0713242787dbf30ef860c3f69152cb87c6392e4973caff5eb178707bbb84c78548e806b2920864a37686bce49425fbfdc4e8c
diff --git a/sci-visualization/gnuplot/gnuplot-5.2.8.ebuild b/sci-visualization/gnuplot/gnuplot-5.2.8.ebuild
new file mode 100644 (file)
index 0000000..b38b2fc
--- /dev/null
@@ -0,0 +1,215 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic readme.gentoo-r1 toolchain-funcs wxwidgets
+
+DESCRIPTION="Command-line driven interactive plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+
+if [[ -z ${PV%%*9999} ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://git.code.sf.net/p/gnuplot/gnuplot-main"
+       EGIT_BRANCH="branch-5-2-stable"
+       MY_P="${PN}"
+       EGIT_CHECKOUT_DIR="${WORKDIR}/${MY_P}"
+else
+       MY_P="${P/_/.}"
+       SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="gnuplot"
+SLOT="0"
+IUSE="aqua bitmap cairo compat doc examples +gd ggi latex libcaca libcerf lua qt5 readline regis svga wxwidgets X"
+
+RDEPEND="
+       cairo? (
+               x11-libs/cairo
+               x11-libs/pango )
+       gd? ( >=media-libs/gd-2.0.35-r3:2=[png] )
+       ggi? ( media-libs/libggi )
+       latex? (
+               virtual/latex-base
+               lua? (
+                       dev-tex/pgf
+                       >=dev-texlive/texlive-latexrecommended-2008-r2 ) )
+       libcaca? ( media-libs/libcaca )
+       lua? ( dev-lang/lua:0 )
+       qt5? (
+               dev-qt/qtcore:5=
+               dev-qt/qtgui:5=
+               dev-qt/qtnetwork:5=
+               dev-qt/qtprintsupport:5=
+               dev-qt/qtsvg:5=
+               dev-qt/qtwidgets:5= )
+       readline? ( sys-libs/readline:0= )
+       libcerf? ( sci-libs/libcerf )
+       svga? ( media-libs/svgalib )
+       wxwidgets? (
+               x11-libs/wxGTK:3.0[X]
+               x11-libs/cairo
+               x11-libs/pango
+               x11-libs/gtk+:2 )
+       X? ( x11-libs/libXaw )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+       virtual/pkgconfig
+       doc? (
+               virtual/latex-base
+               dev-texlive/texlive-latexextra
+               app-text/ghostscript-gpl )
+       qt5? ( dev-qt/linguist-tools:5 )"
+
+S="${WORKDIR}/${MY_P}"
+
+GP_VERSION="${PV%.*}"
+E_SITEFILE="lisp/50${PN}-gentoo.el"
+TEXMF="${EPREFIX}/usr/share/texmf-site"
+
+src_prepare() {
+       eapply "${FILESDIR}"/${PN}-5.0.1-fix-underlinking.patch
+       eapply "${FILESDIR}"/${PN}-5.0.6-no-picins.patch
+       eapply "${FILESDIR}"/${PN}-5.2.2-regis.patch
+       eapply "${FILESDIR}"/${PN}-5.2.6-caca.patch
+       eapply_user
+
+       if [[ -z ${PV%%*9999} ]]; then
+               local dir
+               for dir in config demo m4 term tutorial; do
+                       emake -C "$dir" -f Makefile.am.in Makefile.am
+               done
+       fi
+
+       # Add special version identification as required by provision 2
+       # of the gnuplot license
+       sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
+
+       DOC_CONTENTS='Gnuplot no longer links against pdflib, see the ChangeLog
+               for details. You can use the "pdfcairo" terminal for PDF output.'
+       use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
+       use svga && DOC_CONTENTS+='\n\nIn order to enable ordinary users to use
+               SVGA console graphics, gnuplot needs to be set up as setuid root.
+               Please note that this is usually considered to be a security hazard.
+               As root, manually "chmod u+s /usr/bin/gnuplot".'
+       use gd && DOC_CONTENTS+="\n\nFor font support in png/jpeg/gif output,
+               you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
+               environment variables. See the FAQ file in /usr/share/doc/${PF}/
+               for more information."
+
+       eautoreconf
+
+       # Make sure we don't mix build & host flags.
+       sed -i \
+               -e 's:@CPPFLAGS@:$(BUILD_CPPFLAGS):' \
+               -e 's:@CFLAGS@:$(BUILD_CFLAGS):' \
+               -e 's:@LDFLAGS@:$(BUILD_LDFLAGS):' \
+               -e 's:@CC@:$(CC_FOR_BUILD):' \
+               docs/Makefile.in || die
+}
+
+src_configure() {
+       if ! use latex; then
+               sed -i -e '/SUBDIRS/s/LaTeX//' share/Makefile.in || die
+       fi
+
+       if use wxwidgets; then
+               WX_GTK_VER="3.0"
+               setup-wxwidgets
+       fi
+
+       tc-export CC CXX                        #453174
+       tc-export_build_env BUILD_CC
+       export CC_FOR_BUILD=${BUILD_CC}
+
+       use qt5 && append-cxxflags -std=c++11
+
+       econf \
+               --with-texdir="${TEXMF}/tex/latex/${PN}" \
+               --with-readline=$(usex readline gnu builtin) \
+               $(use_with bitmap bitmap-terminals) \
+               $(use_with cairo) \
+               $(use_enable compat backwards-compatibility) \
+               $(use_with doc tutorial) \
+               $(use_with gd) \
+               "$(use_with ggi ggi "${EPREFIX}/usr/$(get_libdir)")" \
+               "$(use_with ggi xmi "${EPREFIX}/usr/$(get_libdir)")" \
+               "$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
+               $(use_with libcerf) \
+               $(use_with lua) \
+               $(use_with regis) \
+               $(use_with svga linux-vga) \
+               $(use_with X x) \
+               --enable-stats \
+               $(use_with qt5 qt qt5) \
+               $(use_enable wxwidgets) \
+               DIST_CONTACT="https://bugs.gentoo.org/" \
+               EMACS=no
+}
+
+src_compile() {
+       # Prevent access violations, see bug 201871
+       export VARTEXFONTS="${T}/fonts"
+
+       # We believe that the following line is no longer needed.
+       # In case of problems file a bug report at bugs.gentoo.org.
+       #addwrite /dev/svga:/dev/mouse:/dev/tts/0
+
+       emake all
+
+       if use doc; then
+               # Avoid sandbox violation in epstopdf/ghostscript
+               addpredict /var/cache/fontconfig
+               if use cairo && use gd; then
+                       emake -C docs pdf
+               else
+                       ewarn "Cannot build figures unless cairo and gd are enabled."
+                       ewarn "Building documentation without figures."
+                       emake -C docs pdf_nofig
+                       mv docs/nofigures.pdf docs/gnuplot.pdf || die
+               fi
+               emake -C tutorial pdf
+       fi
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+
+       dodoc BUGS ChangeLog NEWS PGPKEYS README* RELEASE_NOTES TODO
+       newdoc term/PostScript/README README-ps
+       newdoc term/js/README README-js
+       use lua && newdoc term/lua/README README-lua
+       readme.gentoo_create_doc
+
+       if use examples; then
+               # Demo files
+               insinto /usr/share/${PN}/${GP_VERSION}
+               doins -r demo
+               rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
+               rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
+       fi
+
+       if use doc; then
+               # Manual, tutorial, FAQ
+               dodoc docs/gnuplot.pdf tutorial/{tutorial.dvi,tutorial.pdf} FAQ.pdf
+               # Documentation for making PostScript files
+               docinto psdoc
+               dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
+       fi
+}
+
+src_test() {
+       GNUTERM="unknown" default_src_test
+}
+
+pkg_postinst() {
+       use latex && texmf-update
+       readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+       use latex && texmf-update
+}