app-emulation/xen: drop vulnerable version
authorTomas Mozes <hydrapolic@gmail.com>
Mon, 4 Nov 2019 08:48:55 +0000 (09:48 +0100)
committerYixun Lan <dlan@gentoo.org>
Mon, 4 Nov 2019 11:50:24 +0000 (11:50 +0000)
Closes: https://github.com/gentoo/gentoo/pull/13543
Bug: https://bugs.gentoo.org/699048
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Signed-off-by: Yixun Lan <dlan@gentoo.org>
app-emulation/xen/Manifest
app-emulation/xen/xen-4.11.2.ebuild [deleted file]

index 522060d34fdf3573617c37b318dc02760e84eb4c..364dcaa0492297ceaf4b475676ee1a9845fe8d43 100644 (file)
@@ -1,4 +1,3 @@
-DIST xen-4.11.2-upstream-patches-0.tar.xz 11532 BLAKE2B e36509d6256ac4018f20711baba77619a7c3a684d81e25a94cffba9c9f53ec9e0efdcefcd6a7ffa26b49fd3d4e0dfc2126f1ea620f0bd35ea83188b4587e5b38 SHA512 4a97d1e56cb3e5152372f0c0b99f8838194b2e03ed1255e87611d8bb28af9c9199fe123d3542f5ba9b3f652c29a519b5e4255b8925c0c8dfbd588f83ed8806d9
 DIST xen-4.11.2-upstream-patches-1.tar.xz 77556 BLAKE2B f95af370f8a99a27bfc762e661364da6f1ef1b08dd5a6b81a5421d32bcad820097a694c5656e174cec7ed53ff140f80d63f57ac31867edf12e68ef4d87ea8b44 SHA512 f41f2ff20648eed76918c865958d42b99d2743188514c63e27797c80e9169f7f5843ac48195e38d269d02edcb9889f042b992b85773ca61c267282e41ea8dae6
 DIST xen-4.11.2.tar.gz 25164925 BLAKE2B 11adea16d93235af5807e6e3784e0fc36ce34f274a85d1976a5c8ad36a323437216b0cf6bb6cb13b00e1e838e319a9f8f4b9c417870eef9ed660f22274d81310 SHA512 48d3d926d35eb56c79c06d0abc6e6be2564fadb43367cc7f46881c669a75016707672179c2cca1c4cfb14af2cefd46e2e7f99470cddf7df2886d8435a2de814e
 DIST xen-4.12.1-upstream-patches-1.tar.xz 62920 BLAKE2B a7f070e4b48c04fa26b75ccbd46aa1172df306060ae180f29f5ea61a5f0b4c2e854a5d1127ed42c05b21977a0e43b36b7e137c1758496b242f48626c5a00e22b SHA512 d7094b86f297a4b1da7007d73752ca8478a26c675ec5d93ade4599935cd51ebd80220a4ea7223d878e0d2c2209336577d196017c463abe9e47ff20914ffa5021
diff --git a/app-emulation/xen/xen-4.11.2.ebuild b/app-emulation/xen/xen-4.11.2.ebuild
deleted file mode 100644 (file)
index b5c663a..0000000
+++ /dev/null
@@ -1,171 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit flag-o-matic mount-boot multilib python-any-r1 toolchain-funcs
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
-
-if [[ $PV == *9999 ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="git://xenbits.xen.org/xen.git"
-       SRC_URI=""
-else
-       KEYWORDS="amd64 ~arm -x86"
-       UPSTREAM_VER=0
-       SECURITY_VER=
-       GENTOO_VER=
-
-       [[ -n ${UPSTREAM_VER} ]] && \
-               UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz
-               https://github.com/hydrapolic/gentoo-dist/raw/master/xen/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
-       [[ -n ${SECURITY_VER} ]] && \
-               SECURITY_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${PN}-security-patches-${SECURITY_VER}.tar.xz"
-       [[ -n ${GENTOO_VER} ]] && \
-               GENTOO_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${PN}-gentoo-patches-${GENTOO_VER}.tar.xz"
-       SRC_URI="https://downloads.xenproject.org/release/xen/${MY_PV}/${MY_P}.tar.gz
-               ${UPSTREAM_PATCHSET_URI}
-               ${SECURITY_PATCHSET_URI}
-               ${GENTOO_PATCHSET_URI}"
-fi
-
-DESCRIPTION="The Xen virtual machine monitor"
-HOMEPAGE="https://www.xenproject.org"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="custom-cflags debug efi flask"
-
-DEPEND="${PYTHON_DEPS}
-       efi? ( >=sys-devel/binutils-2.22[multitarget] )
-       !efi? ( >=sys-devel/binutils-2.22 )"
-RDEPEND=""
-PDEPEND="~app-emulation/xen-tools-${PV}"
-
-# no tests are available for the hypervisor
-# prevent the silliness of /usr/lib/debug/usr/lib/debug files
-# prevent stripping of the debug info from the /usr/lib/debug/xen-syms
-RESTRICT="test splitdebug strip"
-
-# Approved by QA team in bug #144032
-QA_WX_LOAD="boot/xen-syms-${PV}"
-
-REQUIRED_USE="arm? ( debug )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
-       python-any-r1_pkg_setup
-       if [[ -z ${XEN_TARGET_ARCH} ]]; then
-               if use amd64; then
-                       export XEN_TARGET_ARCH="x86_64"
-               elif use arm; then
-                       export XEN_TARGET_ARCH="arm32"
-               elif use arm64; then
-                       export XEN_TARGET_ARCH="arm64"
-               else
-                       die "Unsupported architecture!"
-               fi
-       fi
-
-       if use flask ; then
-               export "XSM_ENABLE=y"
-               export "FLASK_ENABLE=y"
-       fi
-}
-
-src_prepare() {
-       # Upstream's patchset
-       [[ -n ${UPSTREAM_VER} ]] && eapply "${WORKDIR}"/patches-upstream
-
-       # Security patchset
-       if [[ -n ${SECURITY_VER} ]]; then
-       einfo "Try to apply Xen Security patch set"
-               # apply main xen patches
-               # Two parallel systems, both work side by side
-               # Over time they may concdense into one. This will suffice for now
-               source "${WORKDIR}"/patches-security/${PV}.conf
-
-               local i
-               for i in ${XEN_SECURITY_MAIN}; do
-                       eapply "${WORKDIR}"/patches-security/xen/$i
-               done
-       fi
-
-       # Gentoo's patchset
-       [[ -n ${GENTOO_VER} ]] && eapply "${WORKDIR}"/patches-gentoo
-
-       eapply "${FILESDIR}"/${PN}-4.6-efi.patch
-
-       # Drop .config
-       sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
-
-       if use efi; then
-               export EFI_VENDOR="gentoo"
-               export EFI_MOUNTPOINT="boot"
-       fi
-
-       # if the user *really* wants to use their own custom-cflags, let them
-       if use custom-cflags; then
-               einfo "User wants their own CFLAGS - removing defaults"
-               # try and remove all the default custom-cflags
-               find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
-                       -i {} \; || die "failed to re-set custom-cflags"
-       fi
-
-       default
-}
-
-src_configure() {
-       use arm && myopt="${myopt} CONFIG_EARLY_PRINTK=sun7i"
-
-       use debug && myopt="${myopt} debug=y"
-
-       if use custom-cflags; then
-               filter-flags -fPIE -fstack-protector
-               replace-flags -O3 -O2
-       else
-               unset CFLAGS
-               unset LDFLAGS
-               unset ASFLAGS
-       fi
-}
-
-src_compile() {
-       # Send raw LDFLAGS so that --as-needed works
-       emake V=1 CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" LD="$(tc-getLD)" -C xen ${myopt}
-}
-
-src_install() {
-       local myopt
-       use debug && myopt="${myopt} debug=y"
-
-       # The 'make install' doesn't 'mkdir -p' the subdirs
-       if use efi; then
-               mkdir -p "${D}"${EFI_MOUNTPOINT}/efi/${EFI_VENDOR} || die
-       fi
-
-       emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install
-
-       # make install likes to throw in some extra EFI bits if it built
-       use efi || rm -rf "${D}/usr/$(get_libdir)/efi"
-}
-
-pkg_postinst() {
-       elog "Official Xen Guide:"
-       elog " https://wiki.gentoo.org/wiki/Xen"
-
-       use efi && einfo "The efi executable is installed in boot/efi/gentoo"
-
-       elog "You can optionally block the installation of /boot/xen-syms by an entry"
-       elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
-       elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
-}