sys-process/systemd-cron: bump to 1.5.12
authorMike Gilbert <floppym@gentoo.org>
Sat, 9 Dec 2017 18:21:41 +0000 (13:21 -0500)
committerMike Gilbert <floppym@gentoo.org>
Sat, 9 Dec 2017 18:22:20 +0000 (13:22 -0500)
Fixes rootprefix issues.

Closes: https://bugs.gentoo.org/625400
Package-Manager: Portage-2.3.15, Repoman-2.3.6_p7

sys-process/systemd-cron/Manifest
sys-process/systemd-cron/systemd-cron-1.5.12.ebuild [new file with mode: 0644]

index 8a912e0b25a1a1225e2c81f0cb73f0c6b165427b..c18c8f04b7ff06c619f8f6ca1abb8f35bbf6763c 100644 (file)
@@ -1,3 +1,4 @@
 DIST systemd-cron-1.5.10.tar.gz 31191 BLAKE2B c58a0cfec82534baf3daba6f706d054347f3bc5a2d272eb003228b48fc58c9df61ed2045526403295aed3edc9a0c84eaa589c5aea66562bf35d531b4f5ffacd7 SHA512 9a4bbf78c81adf74e589cd9431b5742d5dab63b0346a2330403a7e24bdab62833096445d9fd3e5f6a91f722b3f8176e52734dcc5e2ee0ec23b555e6d01805094
+DIST systemd-cron-1.5.12.tar.gz 31417 BLAKE2B d0776d2c4aa2d86289dd8ab5dade47f083ee7abc16f54c9527130f587049064d6100eaccd4a3a0a461d21ac8286910d3cb0590db14ea1d3a32e591b7ede0a59e SHA512 6f85cef0870cde5ff6b397fb640a30a8a567e09e3cac48456498f1f102395f12f174731ca9cc8e826bb6c49a0d3a6dd49a9aec63e7b75648b7dccfaa499dcea4
 DIST systemd-cron-1.5.3.tar.gz 29105 BLAKE2B c7c95df9be0383aa39a8525d3a5179a04ef1edc77d6c0e34095eb0fe26045c139e4d0c340d6999405baa99d00181cc6c2fb14d87ad401a685aaf3ad7adb5e006 SHA512 ea0241f93b8d92497fa020d84630ee153dc299d9b16b17567784a4dcb5ddf0a4589e7e033428562a862218ef79b192245178df2d7dcc69f779ef9156921674c7
 DIST systemd-cron-1.5.4.tar.gz 30436 BLAKE2B 5ce72e30e68cafbf812690704de4841d0436a97e6a9df12802374a0ef7fe2af4294310e4c14c68d5aa2508c9664402c17dcacb7b6a637f7b83853d97c78c557f SHA512 e6fe60de9d6cbc223b8358bd6b1a060e11f1ea16a8f0b24662914ddb18d827f7b4c62fd40dbefed3d0ac38b1e748998ec5e0430d4ea751e8a20b94b9803bcb89
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.12.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.12.ebuild
new file mode 100644 (file)
index 0000000..f3b6cfa
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( pypy3 python3_{4,5,6} )
+inherit eutils python-single-r1 systemd
+
+DESCRIPTION="systemd units to create timers for cron directories and crontab"
+HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
+SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cron-boot etc-crontab-systemd minutely setgid test yearly"
+
+RDEPEND=">=sys-apps/systemd-217
+            sys-apps/debianutils
+            !etc-crontab-systemd? ( !sys-process/dcron )
+            ${PYTHON_DEPS}
+                sys-process/cronbase"
+
+DEPEND="sys-process/cronbase
+       test? ( sys-apps/man-db dev-python/pyflakes )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+       python_fix_shebang --force "${S}/src/bin"
+
+       sed -i \
+               -e 's/^crontab/crontab-systemd/' \
+               -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
+               -- "${S}/src/man/crontab."{1,5}".in" || die
+
+       sed -i \
+               -e 's!/crontab$!/crontab-systemd!' \
+               -e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
+               -e 's/pyflakes3/pyflakes/' \
+               -- "${S}/Makefile.in" || die
+
+       if use etc-crontab-systemd
+       then    sed -i \
+                       -e "s!/etc/crontab!/etc/crontab-systemd!" \
+                       -- "${S}/src/man/crontab."{1,5}".in" \
+                       "${S}/src/bin/systemd-crontab-generator.py" || die
+       fi
+
+       epatch_user
+}
+
+my_use_enable() {
+       if use ${1}; then
+               echo --enable-${2:-${1}}=yes
+       else
+               echo --enable-${2:-${1}}=no
+       fi
+}
+
+src_configure() {
+       ./configure \
+               --prefix="${EPREFIX}/usr" \
+               --confdir="${EPREFIX}/etc" \
+               --runparts="${EPREFIX}/bin/run-parts" \
+               --mandir="${EPREFIX}/usr/share/man" \
+               --unitdir="$(systemd_get_unitdir)" \
+               --generatordir="$(systemd_get_systemgeneratordir)" \
+               $(my_use_enable cron-boot boot) \
+               $(my_use_enable minutely) \
+               $(my_use_enable yearly) \
+               $(my_use_enable yearly quarterly) \
+               $(my_use_enable yearly semi_annually) \
+               $(my_use_enable setgid) \
+               --enable-persistent=yes
+}