* bump, 0.3.61 goes stable.
authorKonstantin V. Arkhipov <voxus@gentoo.org>
Tue, 31 Oct 2006 18:22:37 +0000 (18:22 +0000)
committerKonstantin V. Arkhipov <voxus@gentoo.org>
Tue, 31 Oct 2006 18:22:37 +0000 (18:22 +0000)
Package-Manager: portage-2.1.2_rc1-r1

www-servers/nginx/ChangeLog
www-servers/nginx/files/digest-nginx-0.4.12 [new file with mode: 0644]
www-servers/nginx/nginx-0.3.61.ebuild
www-servers/nginx/nginx-0.4.12.ebuild [new file with mode: 0644]

index 7ef67226b4a30d0f7039d9bb82f6b02ae577145c..b449bd5cb703ea4bb77bfd4de1f29af74481b5bf 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for www-servers/nginx
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.117 2006/10/25 17:25:55 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.118 2006/10/31 18:22:37 voxus Exp $
+
+*nginx-0.4.12 (31 Oct 2006)
+
+  31 Oct 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+  -nginx-0.3.54.ebuild, -nginx-0.3.57.ebuild, nginx-0.3.61.ebuild,
+  -nginx-0.4.11.ebuild, +nginx-0.4.12.ebuild:
+  Version bump, 0.3.61 goes stable on amd64/x86.
 
 *nginx-0.4.11 (25 Oct 2006)
 
diff --git a/www-servers/nginx/files/digest-nginx-0.4.12 b/www-servers/nginx/files/digest-nginx-0.4.12
new file mode 100644 (file)
index 0000000..c5af21f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b2b9ca9d4fcb5e912dc082b535fd08b9 nginx-0.4.12.tar.gz 435588
+RMD160 43f5155e28a6a9f01ed6ccfc13358f0af5b551a6 nginx-0.4.12.tar.gz 435588
+SHA256 8d6615861a5da15f52f81a8fb51361ee0220c4e9e19f7f6faa4d54f7c32e82fa nginx-0.4.12.tar.gz 435588
index 1d3d46757225612194290326f2cdd728463ce9db..bf87e1f4951913e5e0c83344f4c1f5cbe697656d 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.61.ebuild,v 1.1 2006/09/09 17:27:36 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.61.ebuild,v 1.2 2006/10/31 18:22:37 voxus Exp $
 
 inherit eutils
 
@@ -10,7 +10,7 @@ HOMEPAGE="http://sysoev.ru/nginx/"
 SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
 IUSE="debug fastcgi imap pcre perl threads ssl zlib"
 
 DEPEND="dev-lang/perl
diff --git a/www-servers/nginx/nginx-0.4.12.ebuild b/www-servers/nginx/nginx-0.4.12.ebuild
new file mode 100644 (file)
index 0000000..7b4c675
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.4.12.ebuild,v 1.1 2006/10/31 18:22:37 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+       pcre? ( >=dev-libs/libpcre-4.2 )
+       ssl? ( dev-libs/openssl )
+       zlib? ( sys-libs/zlib )
+       perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+       local myconf
+
+       if use threads; then
+               einfo
+               ewarn "threads support is experimental at the moment"
+               ewarn "do not use it on production systems - you've been warned"
+               einfo
+               myconf="${myconf} --with-threads"
+       fi
+
+       use fastcgi     || myconf="${myconf} --without-http_fastcgi_module"
+       use fastcgi     && myconf="${myconf} --with-http_realip_module"
+       use zlib        || myconf="${myconf} --without-http_gzip_module"
+       use pcre        || {
+               myconf="${myconf} --without-pcre --without-http_rewrite_module"
+       }
+       use debug       && myconf="${myconf} --with-debug"
+       use ssl         && myconf="${myconf} --with-http_ssl_module"
+       use imap        && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+       use perl        && myconf="${myconf} --with-http_perl_module"
+
+       ./configure \
+               --prefix=/usr \
+               --conf-path=/etc/${PN}/${PN}.conf \
+               --http-log-path=/var/log/${PN}/access_log \
+               --error-log-path=/var/log/${PN}/error_log \
+               --pid-path=/var/run/${PN}.pid \
+               --http-client-body-temp-path=/var/tmp/${PN}/client \
+               --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+               --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+               --with-md5-asm --with-md5=/usr/include \
+               ${myconf} || die "configure failed"
+
+       emake || die "failed to compile"
+}
+
+src_install() {
+       keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+       dosbin objs/nginx
+       cp ${FILESDIR}/nginx-r1 ${T}/nginx
+       doinitd ${T}/nginx
+
+       rm conf/nginx.conf
+       cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+       dodir /etc/${PN}
+       insinto /etc/${PN}
+       doins conf/* ${T}/nginx.conf
+
+       dodoc CHANGES{,.ru} LICENSE README
+
+       use perl && {
+               cd ${S}/objs/src/http/modules/perl/
+               make DESTDIR=${D} install || die "failed to install perl stuff"
+       }
+}