net-irc/anope: Improve USE flag naming
authorMichał Górny <mgorny@gentoo.org>
Mon, 23 Sep 2019 07:26:53 +0000 (09:26 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 23 Sep 2019 08:07:09 +0000 (10:07 +0200)
Kill meaningless 'anope_modules_' prefix from flags, and replace
underscores with hyphens.

Closes: https://bugs.gentoo.org/695170
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-irc/anope/anope-2.0.6.ebuild
net-irc/anope/metadata.xml

index aba8b1f9d11fa2f2f2d8697b01d2ea906e41f1f6..1cf036e12d83d14c56c71427a6e82cd42a399acd 100644 (file)
@@ -12,21 +12,20 @@ SRC_URI="https://github.com/anope/anope/releases/download/${PV}/${P}-source.tar.
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="mysql sqlite pcre posix gnutls ssl tre ldap anope_modules_sql_auth
-       anope_modules_sql_log anope_modules_sql_oper anope_modules_ldap_auth
-       anope_modules_ldap_oper anope_modules_irc2sql anope_modules_chanstats
-       anope_modules_cs_fantasy_stats anope_modules_cs_fantasy_top"
+IUSE="chanstats cs-fantasy-stats cs-fantasy-top gnutls irc2sql ldap
+       ldap-auth ldap-oper mysql pcre posix sql-auth sql-log sql-oper
+       sqlite ssl tre"
 
 REQUIRED_USE="
-       anope_modules_sql_auth? ( || ( mysql sqlite ) )
-       anope_modules_sql_oper? ( mysql )
-       anope_modules_sql_log? ( mysql )
-       anope_modules_cs_fantasy_stats? ( anope_modules_chanstats mysql )
-       anope_modules_cs_fantasy_top? ( anope_modules_chanstats mysql )
-       anope_modules_chanstats? ( mysql )
-       anope_modules_irc2sql? ( mysql )
-       anope_modules_ldap_auth? ( ldap )
-       anope_modules_ldap_oper? ( ldap )"
+       chanstats? ( mysql )
+       cs-fantasy-stats? ( chanstats mysql )
+       cs-fantasy-top? ( chanstats mysql )
+       irc2sql? ( mysql )
+       ldap-auth? ( ldap )
+       ldap-oper? ( ldap )
+       sql-auth? ( || ( mysql sqlite ) )
+       sql-log? ( mysql )
+       sql-oper? ( mysql )"
 
 BDEPEND="sys-devel/gettext"
 DEPEND="${BDEPEND}
@@ -75,26 +74,26 @@ src_prepare() {
                fi
        }
 
-       anope_use_extra mysql                                   "m_mysql.cpp"
-       anope_use_extra sqlite                                  "m_sqlite.cpp"
-       anope_use_extra ssl                                     "m_ssl_openssl.cpp"
-       anope_use_extra gnutls                                  "m_ssl_gnutls.cpp"
-       anope_use_extra posix                                   "m_regex_posix.cpp"
-       anope_use_extra pcre                                    "m_regex_pcre.cpp"
-       anope_use_extra tre                                     "m_regex_tre.cpp"
-       anope_use_extra ldap                                    "m_ldap.cpp"
-       anope_use_extra anope_modules_sql_auth                  "m_sql_authentication.cpp"
-       anope_use_extra anope_modules_sql_log                   "m_sql_log.cpp"
-       anope_use_extra anope_modules_sql_oper                  "m_sql_oper.cpp"
-       anope_use_extra anope_modules_ldap_auth                 "m_ldap_authentication.cpp"
-       anope_use_extra anope_modules_ldap_oper                 "m_ldap_oper.cpp"
-       anope_use_extra anope_modules_chanstats                 "stats/m_chanstats.cpp"
-       anope_use_extra anope_modules_cs_fantasy_top            "stats/cs_fantasy_top.cpp"
-       anope_use_extra anope_modules_cs_fantasy_stats          "stats/cs_fantasy_stats.cpp"
-       anope_use_extra anope_modules_irc2sql                   "stats/irc2sql/irc2sql.cpp"
-       anope_use_extra anope_modules_irc2sql                   "stats/irc2sql/irc2sql.h"
-       anope_use_extra anope_modules_irc2sql                   "stats/irc2sql/tables.cpp"
-       anope_use_extra anope_modules_irc2sql                   "stats/irc2sql/utils.cpp"
+       anope_use_extra mysql                   "m_mysql.cpp"
+       anope_use_extra sqlite                  "m_sqlite.cpp"
+       anope_use_extra ssl                     "m_ssl_openssl.cpp"
+       anope_use_extra gnutls                  "m_ssl_gnutls.cpp"
+       anope_use_extra posix                   "m_regex_posix.cpp"
+       anope_use_extra pcre                    "m_regex_pcre.cpp"
+       anope_use_extra tre                     "m_regex_tre.cpp"
+       anope_use_extra ldap                    "m_ldap.cpp"
+       anope_use_extra sql-auth                "m_sql_authentication.cpp"
+       anope_use_extra sql-log                 "m_sql_log.cpp"
+       anope_use_extra sql-oper                "m_sql_oper.cpp"
+       anope_use_extra ldap-auth               "m_ldap_authentication.cpp"
+       anope_use_extra ldap-oper               "m_ldap_oper.cpp"
+       anope_use_extra chanstats               "stats/m_chanstats.cpp"
+       anope_use_extra cs-fantasy-top          "stats/cs_fantasy_top.cpp"
+       anope_use_extra cs-fantasy-stats        "stats/cs_fantasy_stats.cpp"
+       anope_use_extra irc2sql                 "stats/irc2sql/irc2sql.cpp"
+       anope_use_extra irc2sql                 "stats/irc2sql/irc2sql.h"
+       anope_use_extra irc2sql                 "stats/irc2sql/tables.cpp"
+       anope_use_extra irc2sql                 "stats/irc2sql/utils.cpp"
 
        # Avoid a silly sandbox error - tries to delete /usr/lib/modules
        sed -i '/install.*REMOVE_RECURSE.*/d' CMakeLists.txt || die
index 078496567f210e7fb7908436acb3f21241c2a18b..ddb7e3c5b209649a555f24ca4476c061b40f9f9e 100644 (file)
@@ -8,16 +8,16 @@
                <remote-id type="github">anope/anope</remote-id>
        </upstream>
        <use>
-               <flag name="anope_modules_sql_auth">Authorize through SQL</flag>
-               <flag name="anope_modules_sql_log">Additional log target in SQL</flag>
-               <flag name="anope_modules_sql_oper">Allows granting users services operator privileges from SQL</flag>
-               <flag name="anope_modules_ldap_auth">Authorize through LDAP</flag>
-               <flag name="anope_modules_ldap_oper">Dynamically ties users to Anope opertypes via LDAP</flag>
-               <flag name="anope_modules_irc2sql">Stores channel statistics in a mysql database</flag>
-               <flag name="anope_modules_chanstats">Channel Statistics</flag>
-               <flag name="anope_modules_cs_fantasy_stats">Enables the STATS and GSTATS commands</flag>
-               <flag name="anope_modules_cs_fantasy_top">Enables the (G)TOP and  (G)TOP10 commands</flag>
+               <flag name="chanstats">Channel Statistics</flag>
+               <flag name="cs-fantasy-stats">Enables the STATS and GSTATS commands</flag>
+               <flag name="cs-fantasy-top">Enables the (G)TOP and  (G)TOP10 commands</flag>
+               <flag name="irc2sql">Stores channel statistics in a mysql database</flag>
+               <flag name="ldap-auth">Authorize through LDAP</flag>
+               <flag name="ldap-oper">Dynamically ties users to Anope opertypes via LDAP</flag>
                <flag name="posix">Add support for POSIX Compatible Regular Expressions</flag>
+               <flag name="sql-auth">Authorize through SQL</flag>
+               <flag name="sql-log">Additional log target in SQL</flag>
+               <flag name="sql-oper">Allows granting users services operator privileges from SQL</flag>
                <flag name="ssl">Provide SSL services using OpenSSL</flag>
                <flag name="tre">Use <pkg>dev-libs/tre</pkg> for regular expressions</flag>
        </use>